<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<meta name="google-site-verification" content="7uo-_0G6mNbAy4F3c-O0Deze1aVCcTImpJYg7-BiPZ8" />
	<link rel="profile" href="http://gmpg.org/xfn/11"/>
	<link rel="pingback" href="http://www.plumasnews.com/xmlrpc.php"/>
	<title>League hosts forum for council candidates - Plumas News</title>

<!-- This site is optimized with the Yoast SEO plugin v8.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.plumasnews.com/league-hosts-forum-for-council-candidates/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="League hosts forum for council candidates - Plumas News" />
<meta property="og:description" content="With 11 candidates running for a seat on the city council, Portola voters have a choice to make when their..." />
<meta property="og:url" content="http://www.plumasnews.com/league-hosts-forum-for-council-candidates/" />
<meta property="og:site_name" content="Plumas News" />
<meta property="article:publisher" content="http://www.facebook.com/Plumasnews/" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2018-10-11T15:00:39+00:00" />
<meta property="article:modified_time" content="2018-10-04T15:28:30+00:00" />
<meta property="og:updated_time" content="2018-10-04T15:28:30+00:00" />
<meta property="og:image" content="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xa.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="With 11 candidates running for a seat on the city council, Portola voters have a choice to make when their..." />
<meta name="twitter:title" content="League hosts forum for council candidates - Plumas News" />
<meta name="twitter:site" content="@plumasnews" />
<meta name="twitter:image" content="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xa.jpg" />
<meta name="twitter:creator" content="@plumasnews" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.plumasnews.com\/","sameAs":["http:\/\/www.facebook.com\/Plumasnews\/","https:\/\/twitter.com\/plumasnews"],"@id":"http:\/\/www.plumasnews.com\/#organization","name":"Feather Publishing Co","logo":""}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Plumas News &raquo; Feed" href="http://www.plumasnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Plumas News &raquo; Comments Feed" href="http://www.plumasnews.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.plumasnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://www.plumasnews.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='http://www.plumasnews.com/wp-content/plugins/wunderground/assets/css/wunderground.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.plumasnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='es-widget-css-css'  href='http://www.plumasnews.com/wp-content/plugins/email-subscribers/widget/es-widget.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='widgetopts-styles-css'  href='http://www.plumasnews.com/wp-content/plugins/widget-options/assets/css/widget-options.css' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_google_fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_style-css'  href='http://www.plumasnews.com/wp-content/themes/colormag/style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-fontawesome-css'  href='http://www.plumasnews.com/wp-content/themes/colormag/fontawesome/css/font-awesome.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-featured-image-popup-css-css'  href='http://www.plumasnews.com/wp-content/themes/colormag/js/magnific-popup/magnific-popup.css?ver=20150310' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='http://www.plumasnews.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/wp-a11y.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"8ed86b86b7","ajaxurl":"http:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/wunderground/assets/js/widget.min.js?ver=2.1.3'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.10.4'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/advanced-ads-pro/modules/click-fraud-protection/assets/js/cfp.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/colormag-custom.js?ver=4.9.8'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/html5shiv.min.js?ver=4.9.8'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"http:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"1","lazy_load":{"default_offset":200,"offsets":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.2.1'></script>
<link rel='https://api.w.org/' href='http://www.plumasnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.plumasnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.plumasnews.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='http://www.plumasnews.com/?p=13582' />
<link rel="alternate" type="application/json+oembed" href="http://www.plumasnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.plumasnews.com%2Fleague-hosts-forum-for-council-candidates%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.plumasnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.plumasnews.com%2Fleague-hosts-forum-for-council-candidates%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-11530911-1', 'auto');
  ga('send', 'pageview');

</script><script type="text/javascript">
		;var advadsCfpQueue = [], advadsCfpExpHours = 3;
		var advadsCfpClickLimit = 3;
		;
		var advadsCfpPath = '';
		var advadsCfpDomain = 'www.plumasnews.com';
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #828282; }
</style>
<!-- Plumas News Internal Styles -->        <style type="text/css">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</style>
				<style type="text/css" id="wp-custom-css">
			/*remove byline link from posts
.byline {
  display: none;
}*/

/*remove category link from posts*/
/*.cat-links {
  display: none;
}*/

/*expand about us widget across botton*/
.tg-footer-main-widget {
  width: 90%;
}

/*put box around sign-up form*/
.es_widget_form {
    border: 2px solid gray;
    padding: 10px;
    box-shadow: 2px 2px 5px #888888;
}

/*remove some white space around sign-up button*/
.es_button {
  padding-bottom: 0px;
}

/*change submit button color*/
/*#es_txt_button.es_textbox_button {
   background-color: ;
}
*/
/*expand slider across whole page*/
.widget_slider_area {
   width: 70%;
}

/*change nav bar color*/
#site-navigation.main-navigation {
   background-color: #494E58;
}

/*change sub menu color*/
.main-navigation .sub-menu,
.main-navigation .children {
   background-color: #3a3e45;
}
/*thicker search bubble*/
input.s {
  border: 1px solid black ;
}
/*breaking news button*/
a.breaking-news-btn {
  background: #dd3333;
  padding: 10px;
  color: #fff;
  font-weight:bold;
  border-radius:5px;
  box-shadow: 2px 2px 5px #888888;
  display: inline-block;
  width: 290px;
  margin: -8px; 
}
/*breaking news button*/
a.breaking-news-btn:hover {
  background-color: #ff0d0d;
}
/*subscription sign up button*/
a.subscription-btn {
  background: #dd3333;
  padding: 10px;
  color: #fff;
  font-weight: bold;
  border-radius:5px;
  box-shadow: 2px 2px 5px #888888;
  display: inline-block;
  width: 290px;
  margin: -8px; 
}
/*subscription sign up button*/
a.subscription-btn:hover {
  background-color: #ff0d0d;
}
/*thicker email subscribers input box*/
input.es_textbox_class {
  border: 1px solid black ;
}
/*browser disclaimer*/
.widget_slider_area {
	width:100%;
	background: #e5e5e5;
	text-align: center;
}
/*storm button*/
a.storm-btn:hover {
  background-color: #f1f442;
}
/*storm button*/
a.storm-btn {
  background: #f4dc42;
  padding: 10px;
  color: black;
  font-weight: bold;
  border-radius:5px;
  box-shadow: 2px 2px 5px #888888;
  display: inline-block;
  width: 290px;
  margin: -8px;
}
/*reduce padding for tighter nav*/
.main-navigation a {
	padding: 10px 7.5px;
}
/*remove next and previous links on posts*/
.single .default-wp-page {
  display: none;
}
/*house button*/
a.house-btn {
  background: gray;
  padding: 10px;
  color: white;
  font-weight: bold;
  border-radius:5px;
  box-shadow: 2px 2px 5px #888888;
  display: inline-block;
  width: 290px;
  margin: -8px;
}
/*house button*/
a.house-btn:hover {
  background-color: silver;
}
/*change width of widget*/
.widget_slider_area {
   float: left;
   background: white;
   width: 49%;
}
/*change width of widget*/
.widget_beside_slider {
   float: right;
   width: 49%;
}
/*reduce space around nav*/
div#header-text-nav-wrap {
	padding-top: 10px;
	padding-bottom: 0;
}
/*reduce caption font size*/
.wp-caption-text {
	font-size: 14.5px;
}
p {
	font-size: 16px;
}
.footer-socket-wrapper .copyright {
	max-width: 100%;
}

input[type=text],
input[type=tel],
input[type=email],
textarea{
	border: .5px solid gray;
	background-color: #F8F8F8;
	margin: 5px 0px;
}
	input[type=tel]{
	border-radius: 2px;	
	}

hr {
	border-color: #888888;
}		</style>
	</head>

<body class="post-template-default single single-post postid-13582 single-format-standard custom-background ">


<div id="page" class="hfeed site">
	
	
	<header id="masthead" class="site-header clearfix ">
		<div id="header-text-nav-container" class="clearfix">

						<div class="news-bar">
				<div class="inner-wrap clearfix">
					
        <div class="date-in-header">
			Thursday, October 11, 2018        </div>

		
					        <div class="breaking-news">
            <strong class="breaking-news-latest">Latest:</strong>
            <ul class="newsticker">
				                    <li>
                        <a href="http://www.plumasnews.com/league-hosts-forum-for-council-candidates/"
                           title="League hosts forum for council candidates">League hosts forum for council candidates</a>
                    </li>
				                    <li>
                        <a href="http://www.plumasnews.com/pdh-is-one-step-closer-to-u-c-davis-affiliation/"
                           title="PDH is one step closer to U.C. Davis affiliation">PDH is one step closer to U.C. Davis affiliation</a>
                    </li>
				                    <li>
                        <a href="http://www.plumasnews.com/chester-progressive-public-notices-for-the-week-of-10-10-18/"
                           title="Chester Progressive Public Notices for the week of 10/10/18">Chester Progressive Public Notices for the week of 10/10/18</a>
                    </li>
				                    <li>
                        <a href="http://www.plumasnews.com/plumas-district-hospital-selects-new-ceo/"
                           title="Plumas District Hospital  selects new CEO">Plumas District Hospital  selects new CEO</a>
                    </li>
				                    <li>
                        <a href="http://www.plumasnews.com/two-frc-candidates-outline-issues-qualifications-in-nov-6-trustee-race/"
                           title="Two FRC candidates outline issues, qualifications in Nov. 6 trustee race">Two FRC candidates outline issues, qualifications in Nov. 6 trustee race</a>
                    </li>
				            </ul>
        </div>
		
							<div class="social-links clearfix">
			<ul>
				<li><a href="http://www.facebook.com/plumasnews" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="http://www.twitter.com/plumasnews" target="_blank"><i class="fa fa-twitter"></i></a></li>			</ul>
		</div><!-- .social-links -->
						</div>
			</div>
		
			<div id="wp-custom-header" class="wp-custom-header"><div class="header-image-wrap"><a href="http://www.plumasnews.com/" title="Plumas News" rel="home"><img src="http://www.plumasnews.com/wp-content/uploads/2017/09/cropped-plumasnews-flag-masthead.jpg" class="header-image" width="1374" height="300" alt="Plumas News"></a></div></div>

			
			
		<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
			<div class="inner-wrap clearfix">
				
				<h4 class="menu-toggle"></h4>
				<div class="menu-primary-container"><ul id="menu-menu-1" class="menu"><li id="menu-item-381" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-381"><a href="http://www.plumasnews.com/category/news/">News</a></li>
<li id="menu-item-387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-387"><a href="http://www.plumasnews.com/category/sports/">Sports</a></li>
<li id="menu-item-457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-457"><a>Births &#038; Life Tributes</a>
<ul class="sub-menu">
	<li id="menu-item-452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-452"><a href="http://www.plumasnews.com/category/births-life-tributes/births/">Births</a></li>
	<li id="menu-item-451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-451"><a href="http://www.plumasnews.com/category/births-life-tributes/life-tributes/">Life Tributes</a></li>
</ul>
</li>
<li id="menu-item-388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-388"><a target="_blank" href="http://www.plumasnews.com/wp-content/uploads/2017/09/FeatherPubClassys-10-3-18.pdf">Classifieds / Real Estate</a></li>
<li id="menu-item-449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-449"><a>Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-448" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-448"><a href="http://www.plumasnews.com/category/opinion/editorial/">Editorial</a></li>
	<li id="menu-item-450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-450"><a href="http://www.plumasnews.com/category/opinion/my-turn/">My Turn</a></li>
	<li id="menu-item-2861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2861"><a href="http://www.plumasnews.com/category/opinion/where-i-stand/">Where I Stand</a></li>
</ul>
</li>
<li id="menu-item-380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-380"><a href="http://www.plumasnews.com/category/business/">Business</a></li>
<li id="menu-item-4253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4253"><a>Publications</a>
<ul class="sub-menu">
	<li id="menu-item-4252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4252"><a href="http://www.plumasnews.com/plumas-county-visitors-guide/">Plumas County Visitors Guide</a></li>
	<li id="menu-item-4251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4251"><a href="http://www.plumasnews.com/plumas-county-dining-guide/">Plumas County Dining Guide</a></li>
	<li id="menu-item-4250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4250"><a href="http://www.plumasnews.com/plumas-county-book-maps/">Plumas County Book of Maps</a></li>
	<li id="menu-item-10460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10460"><a href="http://www.plumasnews.com/wp-content/uploads/2018/05/YP-PLUMAS2018-19.pdf">Plumas-Lassen Connection</a></li>
	<li id="menu-item-4248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4248"><a href="http://www.plumasnews.com/paying-tribute-150th-anniversary/">Paying Tribute to our 150th Anniversary</a></li>
	<li id="menu-item-4744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4744"><a href="http://www.lassennews.com">Lassen News</a></li>
	<li id="menu-item-10461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10461"><a href="http://www.lassennews.com/lassen-county-visitors-guide/">Lassen County Visitors Guide</a></li>
</ul>
</li>
<li id="menu-item-458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-458"><a>Public Notices</a>
<ul class="sub-menu">
	<li id="menu-item-385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-385"><a href="http://www.plumasnews.com/category/public-notices/plumas-county-wide-public-notices/">Plumas County-wide</a></li>
	<li id="menu-item-386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-386"><a href="http://www.plumasnews.com/category/public-notices/portola-reporter-public-notices/">Portola Reporter</a></li>
	<li id="menu-item-383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-383"><a href="http://www.plumasnews.com/category/public-notices/feather-river-bulletin-public-notices/">Feather River Bulletin</a></li>
	<li id="menu-item-384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-384"><a href="http://www.plumasnews.com/category/public-notices/indian-valley-record-public-notices/">Indian Valley Record</a></li>
	<li id="menu-item-382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-382"><a href="http://www.plumasnews.com/category/public-notices/chester-progressive-public-notices/">Chester Progressive</a></li>
	<li id="menu-item-1230" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1230"><a href="http://www.plumasnews.com/category/public-notices/lassen-county-public-notices/">Lassen County</a></li>
	<li id="menu-item-389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389"><a target="_blank" href="http://www.capublicnotice.com">Statewide Public Notices</a></li>
</ul>
</li>
<li id="menu-item-454" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-454"><a>More &#8230;</a>
<ul class="sub-menu">
	<li id="menu-item-483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-483"><a target="_blank" href="http://www.plumasnews.com/wp-content/uploads/2016/12/06B-07B-Common-DAP.pdf">Small Business and Services Network</a></li>
	<li id="menu-item-514" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-514"><a href="http://www.plumasnews.com/events-calendar/">Events Calendar</a></li>
	<li id="menu-item-453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-453"><a href="http://www.plumasnews.com/category/remember-when/">Remember When</a></li>
	<li id="menu-item-491" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-491"><a href="http://www.plumasnews.com/submission-guidlines/">Submission Guidelines</a></li>
	<li id="menu-item-456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-456"><a href="http://www.plumasnews.com/weather-road-conditions/">Weather &#038; Road Conditions</a></li>
</ul>
</li>
<li id="menu-item-459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-459"><a href="http://www.plumasnews.com/contact/">Contact Us</a></li>
</ul></div>
				
							</div>
		</nav>

					
			
		<div class="inner-wrap">

			<div id="header-text-nav-wrap" class="clearfix">
				<div id="header-left-section">
										<div id="header-text" class="screen-reader-text">
													<h3 id="site-title">
								<a href="http://www.plumasnews.com/" title="Plumas News" rel="home">Plumas News</a>
							</h3>
																		<p id="site-description">Plumas County News</p>
						<!-- #site-description -->
					</div><!-- #header-text -->
				</div><!-- #header-left-section -->
				<div id="header-right-section">
									</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->

		</div><!-- .inner-wrap -->

		
		</div><!-- #header-text-nav-container -->

		
	</header>

		
	<div id="main" class="clearfix">
		<div class="inner-wrap clearfix">
<div class="front-page-top-section clearfix">
		<div class="widget_slider_area">
			<section class="widget pluma-widget clearfix"><div id="pluma-658e976632fdef033da5d968b9790e2b"></div></section>		</div>

		<div class="widget_beside_slider">
			<section class="widget pluma-widget clearfix"><div id="pluma-c53f41b37b1ba03173a8bbd1a6f65283"></div></section>		</div>
	</div>
	
	<div id="primary">
		<div id="content" class="clearfix">

			
				
<article id="post-13582" class="post-13582 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
	
   
         <div class="featured-image">
               <a href="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xa.jpg" class="image-popup"><img width="800" height="445" src="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xa-800x445.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" srcset="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xa-800x445.jpg 800w, http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xa-150x84.jpg 150w" sizes="(max-width: 800px) 100vw, 800px" /></a>
            </div>
   	<div class="caption-content">
                    <p class="caption">Ten of the 11 candidates for Portola City Council attend the Plumas County League of Women Voters forum held in Portola on Sept. 27. Photos by Debra Moore
</p>
</div>

   <div class="article-content clearfix">

   
   <div class="above-entry-meta"><span class="cat-links"><a href="http://www.plumasnews.com/category/news/" style="background:#848484" rel="category tag">News</a>&nbsp;</span></div>
      <header class="entry-header">
   		<h1 class="entry-title">
   			League hosts forum for council candidates   		</h1>
   	</header>

   	<div class="below-entry-meta">
			<span class="posted-on"><a href="http://www.plumasnews.com/league-hosts-forum-for-council-candidates/" title="8:00 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2018-10-11T08:00:39+00:00">October 11, 2018</time><time class="updated" datetime="2018-10-04T08:28:30+00:00">October 4, 2018</time></a></span>
            <span class="byline"><span class="author vcard"><i class="fa fa-user"></i><a class="url fn n"
                                                                                         href=""
                                                                                         title="Debra Moore, Managing Editor">Debra Moore, Managing Editor</a></span></span>

			</div>
   	<div class="entry-content clearfix">
   		<div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_26 addtoany_list" data-a2a-url="http://www.plumasnews.com/league-hosts-forum-for-council-candidates/" data-a2a-title="League hosts forum for council candidates"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.plumasnews.com%2Fleague-hosts-forum-for-council-candidates%2F&amp;linkname=League%20hosts%20forum%20for%20council%20candidates" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.plumasnews.com%2Fleague-hosts-forum-for-council-candidates%2F&amp;linkname=League%20hosts%20forum%20for%20council%20candidates" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_plus" href="https://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.plumasnews.com%2Fleague-hosts-forum-for-council-candidates%2F&amp;linkname=League%20hosts%20forum%20for%20council%20candidates" title="Google+" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.plumasnews.com%2Fleague-hosts-forum-for-council-candidates%2F&amp;linkname=League%20hosts%20forum%20for%20council%20candidates" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><script type="text/javascript">
        (function() {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            var ACCOUNT_ID = '_vepabzehjds5ogfduaswd4fa2a';
            document.write(
                '<scr'+'ipt '+
                'src="//survey.g.doubleclick.net/survey?site='+ACCOUNT_ID+
                '&amp;url='+encodeURIComponent(ARTICLE_URL)+
                (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
                '&amp;random='+(new Date).getTime()+
                '" type="text/javascript">'+'</scr'+'ipt>');
        })();
</script><div class="p402_premium"><p class="p1">With 11 candidates running for a seat on the city council, Portola voters have a choice to make when their ballots arrive in the mail next week.</p>
<p class="p1">Ten of the 11 attended a forum hosted by the League of Women Voters at the Portola Memorial Hall on Thursday evening, Sept. 27, which was sparsely attended. But those who were in the building heard from a group that ranged from the very-new-to-politics to seasoned veterans with years, if not decades, in office.</p>
<p class="p1">There are seven vying for a two-year term: Max Bradshaw, Larry Douglas, Tim Kreth, Pat Morton, B.J. Pearson, Stan Peiler and Kim Scott. Four are vying for a four-year term: Phil Oels, Bill Powers, Casey Williams and Terri Woods. The League made no distinction between the two groups during the evening, with Lori Simpson moderating the event and asking the questions.</p>
<p class="p1">As is custom with the League, each candidate was allowed a two-minute opening statement. Some came with prepared remarks, others adlibbed. They began the intros in alphabetical order. Max Bradshaw, a retiree, had told the League he would unable to attend.</p>
<p class="p1">Larry Douglas, who has held a city council seat in the past and is a regular attendee of the meetings, read a prepared statement in which he described “the current state of the city as hopeless” and cited its many problems, including the infrastructure, poverty and vacant buildings. His plan is to jump start the economy.</p>
<p class="p1">Tim Kreth, who is a self-employed businessman, admitted he was new to the process and was there because people told him “that he had to run.” Kreth said that as someone who has been in Portola his entire life, he has witnessed a loss of community spirit. “It’s good to get some of the younger generation people involved,” he said.</p>
<p class="p1">Pat Morton, an incumbent, told the audience that she has the time and knows the issues. She too cited the city’s issues with infrastructure — roads, water, sewer — as well as blight. But she is optimistic that the city soon will be receiving a grant to address the infrastructure.</p>
<p class="p1">Phil Oels, another incumbent, is concerned with the threat of wildfire to Portola, and focused his opening remarks on that topic. “I have the long-term goal of building a fire safe perimeter around the city,” he said. He also discussed his ongoing opposition to water and sewer rate increases. He concluded with, “Let my record speak for itself.”</p>
<p class="p1">B.J. Pearson, who has served twice on the city council and a term on the county board of supervisors, said a friend asked him, “Why in the world are you doing this?” He said that he has been observing the council for the past 15 years and the “job seems to have become ceremonial.” He said the city, which was founded on logging and the railroad, now has to find another source of economic revenue.</p>
<p class="p1">Stan Peiler, who has been a resident of Portola for 13 years, is one of the newcomers to city politics. “I offer honesty and to listen to you with an open ear,” he said.</p>
<p class="p1">Bill Powers, an incumbent, has also served on the city council and as a county supervisor. He said that the city has gotten a bad reputation and “things are falling apart around us.” He too mentioned the $35 million grant that will help with the sewer and water, as well as paving. He sees a new spirit beginning for the city that involves recreation.</p>
<p class="p1">Kim Scott described herself as a member of the Cannabis Working Group and coauthor of Measure B. “I want to see Portola regain some of its economy,” she said. She, like Tim Kreth, said that people asked her “to step up.” She also said that she’s more concerned with the people of Portola than with tourists.</p>
<p class="p1">Casey Williams, who works with the local group One Life Fully Lived, said she is running for the council for three reasons: to find ways to bring more money into the community via recreation tourism, complete the infrastructure, and bring back a sense of pride to the community.</p>
<p class="p1">Terri Woods said she moved to the city 17 years ago to open a business and then experienced the economic downturn that began in 2008. “People are moving out of the city,” she said and discussed the lack of opportunity for high school students when they graduate. She has regularly attended city council meetings for the past five years and twice ran unsuccessfully for a seat on the council. She too addressed the infrastructure problems.</p>
<figure id="attachment_13506" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xb.jpg"><img class="size-full wp-image-13506" src="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xb.jpg" alt="" width="800" height="390" srcset="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xb.jpg 800w, http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xb-150x73.jpg 150w, http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xb-400x195.jpg 400w, http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xb-768x374.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption class="wp-caption-text">Stan Peiler, left, and Kim Scott listen as Bill Powers responds to a question during a forum for Portola City Council candidates. Powers, an incumbent, is seeking a four-year term. Peiler and Scott are vying for a two-year term.</figcaption></figure>
<p class="p5"><b>A youth center</b></p>
<p class="p1">When asked to comment on a potential youth center for Portola, the candidates focused on opportunities for youth — both recreational and vocational.</p>
<p class="p1">Kim Scott said that she was investigating the possibility of starting a Boys and Girls Club of Portola and has met with the city manager to find an available building.</p>
<p class="p1">Bill Powers is also investigating that opportunity and has served as a trainer for the program in Kings Beach near Tahoe, and hoped that Portola could become an extension. He said a problem for youth centers is that they are expensive to operate, but that some state mental health funding could be available.</p>
<p class="p1">B.J. Pearson said that he “started and financed three different programs for youth,” including one that councilman Phil Oels went through. He also discussed the high school program that had students building homes.</p>
<p class="p1">Pat Morton also addressed the latter and said that the students built five homes and discussed the need for those sorts of vocational classes. “We need plumbers, electricians, landscapers,” she said.</p>
<p class="p1">Phil Oels is also a proponent of vocational education. “They need skills to go straight to work,” he said. “Not everyone is bound for college.”</p>
<p class="p1">“The answer for youth is education,” Larry Douglas said.</p>
<p class="p1"><b>Economy, infrastructure and downtown</b></p>
<p class="p1">Moderator Lori Simpson asked the candidates to discuss how to jumpstart the economy, and address the city’s infrastructure and downtown appearance.</p>
<p class="p1">Larry Douglas said that he restored his home on Commercial Street and helped with landscaping projects downtown. He said that the vision for Portola is laid out in its general plan and it needs to be implemented.</p>
<p class="p1">Tim Kreth wants to “pump life back into the community spirit” and then the economy will follow.</p>
<p class="p1">“I agree with Tim,” Pat Morton said, echoing his call to rebuild community spirit and “to bring that sense of pride back.” She said that a problem facing Portola is lack of volunteers.</p>
<p class="p1">Phil Oels said that jobs have always been a problem for Portola, but he sees the work with making the community fire safe as a way to begin. “There are three places to sell chips (wood chips from forest thinning) for power,” he said.</p>
<p class="p1">“It’s hard to promote pride when you have one of the highest welfare rates in the nation,” B.J. Pearson said. He wants to restore the city through “packaged development” and encourages residents to stop by his real estate office for details of his plans.</p>
<p class="p1">Stan Peiler compared the first Railroad Days he attended 13 years ago with all of its attractions, to recent efforts. As for the infrastructure, he suggested tackling it in sections so that residents could see a difference.</p>
<p class="p1">Bill Powers said that “almost 40 percent of the workforce” in Portola commutes to Reno to work, which not only means that those people are spending their grocery money there, but they are too tired to volunteer by the time they return home. He wants to bring the workforce back to the city and said it has to be through recreation.</p>
<p class="p1">Casey Williams also sees recreation as key and noted the number of visitors who flock to the Graeagle area just down the road. “All these people are there spending money all summer long,” she said. “If we can tap into those people. …” She said that outdoor recreation is a good way to bring people in and bolsters lodging, restaurants and more.</p>
<p class="p1">“People expect me to say cannabis,” Kim Scott said, “and you’re right.” She added that cannabis “would infuse everything else we’re missing.”</p>
<p class="p1">“I know the problems,” said Terri Woods and asked the audience how many people actually come to the city council meetings. “Don’t complain,” she said. “Come to city council.” She said that she videotapes the meetings and posts them on her website.</p>
<figure id="attachment_13507" style="width: 800px" class="wp-caption aligncenter"><a href="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xc.jpg"><img class="size-full wp-image-13507" src="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xc.jpg" alt="" width="800" height="402" srcset="http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xc.jpg 800w, http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xc-150x75.jpg 150w, http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xc-400x201.jpg 400w, http://www.plumasnews.com/wp-content/uploads/2018/10/Pforum-4xc-768x386.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><figcaption class="wp-caption-text">B.J. Pearson answers a question during a League of Women Voters forum Sept. 27, while other candidates listen and wait their turn. From left: Pat Morton, Phil Oels, Pearson and Stan Peiler.</figcaption></figure>
<p class="p6"><b>Cannabis</b></p>
<p class="p1">Moderator Lori Simpson combined three questions under this topic: When would you lift the moratorium? Do you support Measure B? How do you feel about someone growing commercially next door to you?</p>
<p class="p1">Stan Peiler said that he had more to learn on the subject, but if it works for the city’s economy that would be great. However he “wouldn’t be comfortable with someone growing next door” to his home.</p>
<p class="p1">B.J. Pearson said that he doesn’t even smoke cigarettes, but the decision has been made and the city has to prepare for it. He opposes growing cannabis in neighborhoods, but that he would “treat it like any other industry” and ensure that it is regulated and patrolled.</p>
<p class="p1">Phil Oels said that the moratorium should be lifted, but that he is opposed to large commercial grows.</p>
<p class="p1">Pat Morton said that the city doesn’t have room for large commercial grows. She isn’t against marijuana, but would want it regulated.</p>
<p class="p1">“I have a similar stand,” said Tim Kreth. He added that he “never enjoyed it as a user,” and is concerned about the terrible smell that comes during harvest time. However, he knows that there is a lot of money in it.</p>
<p class="p1">“It’s quite an issue for the city and county,” Larry Douglas said. “It’s not the use of; it’s the abuse of …” He said the revenue doesn’t offset the expense of enforcing the codes. He thinks the city “should grow fish” instead by creating fisheries.</p>
<p class="p1">Terri Woods said that she is quite familiar with the industry and supports medical marijuana, but doesn’t support Measure B, citing its lack of transparency and other issues. “Lawsuits will come,” she said.</p>
<p class="p1">Casey Williams said that she doesn’t support commercial growing in the city and knows of grows in the valley that have not been a good experience.</p>
<p class="p1">Kim Scott reminded those in attendance that she was the coauthor of Measure B. “I spent a year on the working group; I support it,” she said. She said that she wouldn’t put cultivation in the city, but there were “plenty of other cannabis businesses” that would be appropriate.</p>
<p class="p1">Bill Powers said that when the voters passed Proposition 64, the city “got busy and set our own regulations and rules.”</p>
<p class="p1"><b>Fire Department</b></p>
<p class="p1">Moderator Simpson posed the following question submitted from the audience: “We lost our fire department; how do we get it back?”</p>
<p class="p1">“It was a personal loss,” said Phil Oels. He said that a main issue was a lack of volunteers and their need to pay for their own training. “Portola needs to have its own fire department,” he said. “It’s always been a source of pride.” He said that the volunteers donated their time far beyond the department and it’s been a loss to the community.</p>
<p class="p1">Pat Morton explained that the department was “put on administrative stand down because of a lack of qualified volunteers.” She said that the two-year contract with Eastern Plumas has been working well and local volunteers are being trained there. “We hope to open the department back up,” she said.</p>
<p class="p1">Tim Kreth said he didn’t know the particulars of why it closed, but he was sad to see it go. He said that he had been a part of Eastern Plumas Fire as a kid and remembered the volunteer work associated with the department. “It’s kind of a black mark on the city,” he said.</p>
<p class="p1">Larry Douglas said he too, hadn’t known why the department closed, but had heard there were problems with the EMS response. “Eastern Plumas has been doing a fantastic job,” he said, adding that if Portola were to get its fire department back it should pay for training.</p>
<p class="p1">Terri Woods also appreciated the work of Eastern Plumas and cited the lack of training as being the issue for Portola Fire.</p>
<p class="p1">Casey Williams said the city definitely had to get the department back up and running and needed to pay for the training.</p>
<p class="p1">Kim Scott said that there wasn’t much to add to what had already been said other than it would be a good time to reevaluate what the city needs in a fire department.</p>
<p class="p1">Bill Powers discussed the long-standing competition between the Eastern Plumas and Portola fire departments, as well as the possibility of consolidating the two. He mentioned the issues affecting rural fire departments across the nation and said that Portola isn’t alone. Powers also discussed the need to involve younger people in the department and suggested that since it can take up so much time, that perhaps they would need “twice as many people to work half the time.”</p>
<p class="p1">Stan Peiler suggested that department veterans could be recruited to write policies and procedures; and that the community should do something to recognize the firefighters such as hosting quarterly dinners “just to thank the fire department.”</p>
<p class="p1">“I was waiting for this one,” B.J. Pearson said. “Health and safety is most important.” He added, “The fire department didn’t just shutdown overnight. Some of the people sitting here oversaw the decline.” He wants to recruit firefighters from the Bay Area, and said, “If I get elected, we will have a fire department. Period.”</p>
<p class="p1"><b>In closing</b></p>
<p class="p1">In their closing remarks, the candidates were asked to include information about how many council meetings they had attended, as well as how they would restore integrity to the council, and why there were so few people in attendance at the forum.</p>
<p class="p1">“I ran for city council twice and lost twice,” Terri Woods said. “Some people think tourism and marijuana will save the city.” She thinks the priorities must include cleaning up the city and its infrastructure. She said she would study the budget and prioritize projects.</p>
<p class="p1">Casey Williams said she began attending city council meetings in July because she wanted to be current with what was happening in the city. She said the fact that there are 11 people running for council indicates that people want a change — “fresh minds and new perspective.”</p>
<p class="p1">“I don’t want people to think it’s only about cannabis,” Kim Scott said. She thinks the city would benefit from doing an economic study and discover where to best direct resources. “Cannabis may not be the answer; we need other plans,” she said. She also said that “people in the city feel like second class citizens and that’s why they are not here.”</p>
<p class="p1">Bill Powers said that the city needs an economic plan and to bring its workers back from Reno. “The town was built with the railroads and the mill; now we need a new engine,” he said.</p>
<p class="p1">“I want to thank all of the candidates,” Stan Peiler said. “We care enough about the city to be in front of all of you.” He said that his commitment would not change and his focus would be on youth, infrastructure and the elderly.</p>
<p class="p1">B.J. Pearson said, “Every candidate has stressed two things: jobs and youth.” He thinks that development is the answer and mentioned his subdivision work. He encouraged the audience to Google his name and/or to stop by his office. “If you want a future for your children, then vote for me,” he said.</p>
<p class="p1">Phil Oels said that Portola has its problems, but as a community, there is strength to deal with them. He described his job as 80 percent listening and 20 percent doing and that at $300 per month, he jokes that he isn’t sure if he makes 3 cents or 4 cents per hour.</p>
<p class="p1">Pat Morton encouraged anyone to call her at 832-5880. She said that patience and persistence are needed for the position and to solve the city’s problems.</p>
<p class="p1">“I’m not a politician,” Tim Kreth said. “I’m grateful for the opportunity to come here.” He said that he needed to attend more council meetings and that he had the ability to interface with all types of people. “My intention will be to unify people,” he said.</p>
<p class="p1">Larry Douglas said that he had been attending city council meetings since 2003 and served on the council in 2004. “I am a self-employed watchdog,” he said.</p>
<p class="p1">Ballots are set to be mailed out beginning Oct. 9 and must be returned or postmarked by Nov. 6.</p>
</div><script type="text/javascript">try { _402_Show(); } catch(e) {}</script>   	</div>

   </div>

	</article>

			
		</div><!-- #content -->

      
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="http://www.plumasnews.com/pdh-is-one-step-closer-to-u-c-davis-affiliation/" rel="prev"><span class="meta-nav">&larr;</span> PDH is one step closer to U.C. Davis affiliation</a></li>
			<li class="next"></li>
		</ul>
	
      
      
      
	</div><!-- #primary -->

	
<div id="secondary">
			
		<aside id="search-2" class="widget widget_search clearfix"><form action="http://www.plumasnews.com/" class="search-form searchform clearfix" method="get">
   <div class="search-wrap">
      <input type="text" placeholder="Search" class="s field" name="s">
      <button class="search-icon" type="submit"></button>
   </div>
</form><!-- .searchform --></aside><aside id="text-4" class="widget widget_text clearfix">			<div class="textwidget"><a href=" http://www.plumasnews.com/contact/" class="subscription-btn" style="text-decoration: none">Sign up for a newspaper subscription</a>
</div>
		</aside><aside class="widget pluma-widget clearfix"><div id="pluma-76918b08fcbb626270ab55145df119da"></div></aside>
	</div>
	

</div><!-- .inner-wrap -->
</div><!-- #main -->




<footer id="colophon" class="clearfix ">
	
<div class="footer-widgets-wrapper">
	<div class="inner-wrap">
		<div class="footer-widgets-area clearfix">
         <div class="tg-footer-main-widget">
   			<div class="tg-first-footer-widget">
   				<aside id="text-2" class="widget widget_text clearfix"><h3 class="widget-title"><span>About Us</span></h3>			<div class="textwidget"><p><strong>Feather Publishing Co. Inc. — Serving Plumas County</strong></p>
<p><strong>Ownership:</strong><br />
Feather Publishing Co., Inc., publishes four weekly papers in Plumas County: the Feather River Bulletin, Chester Progressive, Indian Valley Record, and Portola Reporter and two weekly papers in Lassen County: the Lassen County Times and the Westwood Pine Press.</p>
<p><strong>Frequency:</strong><br />
All papers are published on Wednesday except the Lassen County Times which is published on Tuesday.</p>
<hr />
<p><a href="http://www.plumasnews.com/privacy-policy-2/">Privacy Policy</a></p>
</div>
		</aside>   			</div>
         </div>
         <div class="tg-footer-other-widgets">
   			<div class="tg-second-footer-widget">
   				   			</div>
            <div class="tg-third-footer-widget">
                           </div>
            <div class="tg-fourth-footer-widget">
                           </div>
         </div>
		</div>
	</div>
</div>	<div class="footer-socket-wrapper clearfix">
		<div class="inner-wrap">
			<div class="footer-socket-area">
				<div class="footer-socket-right-section">
							<div class="social-links clearfix">
			<ul>
				<li><a href="http://www.facebook.com/plumasnews" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="http://www.twitter.com/plumasnews" target="_blank"><i class="fa fa-twitter"></i></a></li>			</ul>
		</div><!-- .social-links -->
						</div>

				<div class="footer-socket-left-section">
					<div class="copyright">Copyright &copy; 2018 <a href="http://www.plumasnews.com/" title="Plumas News" ><span>Plumas News</span></a>. All rights reserved.<br></div>				</div>
			</div>
		</div>
	</div>
</footer>

<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>

</div><!-- #page -->
<script>
		var advanced_ads_ga_UID = false;
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();		
		</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.plumasnews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_page_notices = {"es_email_notice":"Please enter email address","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Kindly check your mailbox and confirm your subscription. If you don't see the email within a few minutes, check the spam\/junk folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_ajax_url":"http:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/email-subscribers/widget/es-widget-page.js?ver=4.9.8'></script>
<script type='text/javascript'>
var renderInvisibleReCaptcha = function() {

    for (var i = 0; i < document.forms.length; ++i) {
        var form = document.forms[i];
        var holder = form.querySelector('.inv-recaptcha-holder');

        if (null === holder) continue;
		holder.innerHTML = '';

         (function(frm){
			var cf7SubmitElm = frm.querySelector('.wpcf7-submit');
            var holderId = grecaptcha.render(holder,{
                'sitekey': '6LdbLyIUAAAAANyBnSa49kZ4yVSmvqwoCI2GAJPi', 'size': 'invisible', 'badge' : 'inline',
                'callback' : function (recaptchaToken) {
					if((null !== cf7SubmitElm) && (typeof jQuery != 'undefined')){jQuery(frm).submit();grecaptcha.reset(holderId);return;}
					 HTMLFormElement.prototype.submit.call(frm);
                },
                'expired-callback' : function(){grecaptcha.reset(holderId);}
            });

			if(null !== cf7SubmitElm && (typeof jQuery != 'undefined') ){
				jQuery(cf7SubmitElm).off('click').on('click', function(clickEvt){
					clickEvt.preventDefault();
					grecaptcha.execute(holderId);
				});
			}
			else
			{
				frm.onsubmit = function (evt){evt.preventDefault();grecaptcha.execute(holderId);};
			}


        })(form);
    }
};
</script>
<script type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?onload=renderInvisibleReCaptcha&#038;render=explicit'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/jquery.bxslider.min.js?ver=4.2.10'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/colormag-slider-setting.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/navigation.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/news-ticker/jquery.newsTicker.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/news-ticker/ticker-setting.js?ver=20150304'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/magnific-popup/jquery.magnific-popup.min.js?ver=20150310'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/magnific-popup/image-popup-setting.js?ver=20150310'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/fitvids/jquery.fitvids.js?ver=20150311'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/themes/colormag/js/fitvids/fitvids-setting.js?ver=20150311'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advadsTracking = {"ajaxurl":"http:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track","method":"shutdown","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.8.13'></script>
<script type='text/javascript' src='http://www.plumasnews.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script>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</script><script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = {"1":"http:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php?action=advanced-ads-tracking-track"};var advads_gatracking_uids = {"1":""};var advads_tracking_methods = {"1":"shutdown"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"http:\/\/www.plumasnews.com\/linkout\/"};var advads_gatracking_allads = {"1":{"13358":{"title":"FRC 50th","target":"http:\/\/www.plumasnews.com\/wp-content\/uploads\/2018\/09\/50th-Invitation-2.pdf"},"13348":{"title":"Juli Thompson - Dickson Realty","target":"http:\/\/highsierrarealestate.com"},"9143":{"title":"Nevada Museum of Art","target":"https:\/\/www.nevadaart.org\/"},"4496":{"title":"Dickson Realty","target":"http:\/\/www.dicksonrealty.com\/offices\/1719-Graeagle"},"3677":{"title":"Feather Publishing - House ad","target":"http:\/\/www.plumasnews.com\/contact\/"},"1232":{"title":"Plumas Bank","target":"http:\/\/www.plumasbank.com"},"1228":{"title":"Evergreen Market","target":"http:\/\/www.evergreenmarket.biz\/"},"1126":{"title":"Bonanza Casino","target":"http:\/\/bonanzacasino.com"},"971":{"title":"Farmers (Linda Rouland)","target":false},"968":{"title":"Coldwell Banker","target":"http:\/\/www.sellingplumascounty.com\/"},"967":{"title":"Almanor Energy","target":"http:\/\/www.almanorenergy.com\/"},"966":{"title":"Plumas District Hospital","target":"http:\/\/www.pdh.org\/"},"964":{"title":"Richard Stockton","target":"http:\/\/www.richardstockton.us\/"},"962":{"title":"Plumas Crisis Intervention - PCIRC","target":"http:\/\/www.pcirc1.org"},"961":{"title":"Camp Layman","target":"http:\/\/www.camplayman.com"},"958":{"title":"Town and Country","target":"http:\/\/townandcountryprops.com\/"},"957":{"title":"Seneca Healthcare","target":"http:\/\/www.senecahospital.org\/"},"955":{"title":"Dupont Power Tool","target":"http:\/\/www.dupontpowertool.com\/"}}};var advads_gatracking_anonym = true;</script></body>
</html>
