<!DOCTYPE html><html lang="en-US"><head><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11" /><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <!-- Optimized by SG Optimizer plugin version - 5.7.17 --> <!-- This site is optimized with the Yoast SEO plugin v16.0.1 - https://yoast.com/wordpress/plugins/seo/ --><title>Quincy Weather Summary March 26, 2021 - Plumas News</title><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin/><style type="text/css">@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0e.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 600;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOUuhs.ttf) format('truetype');
} </style><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0bf8pkAg.woff2" crossorigin/><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOUuhpKKSTjw.woff2" crossorigin/><link rel="preload" as="font" href="https://www.plumasnews.com/wp-content/themes/colormag/fontawesome/fonts/fontawesome-webfont.woff2?v=4.7.0" crossorigin/><link rel="stylesheet" id="siteground-optimizer-combined-css-fbf7e7314e59d77857b293448a494509" href="https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-fbf7e7314e59d77857b293448a494509.css" media="all" /><link rel="canonical" href="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Quincy Weather Summary March 26, 2021 - Plumas News" /><meta property="og:description" content="Quincy Weather March 19 – March 26, 2021 Compiled By Ron Trumbo  Date            Hi            Lo            Rain – Snow (Inches) March" /><meta property="og:url" content="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/" /><meta property="og:site_name" content="Plumas News" /><meta property="article:publisher" content="http://www.facebook.com/Plumasnews/" /><meta property="article:published_time" content="2021-03-27T00:48:23+00:00" /><meta property="og:image" content="https://www.plumasnews.com/wp-content/uploads/2019/01/fb-social-sharing-H-1.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="630" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@plumasnews" /><meta name="twitter:site" content="@plumasnews" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Submitted"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.plumasnews.com/#website","url":"https://www.plumasnews.com/","name":"Plumas News","description":"Plumas County News","potentialAction":[{"@type":"SearchAction","target":"https://www.plumasnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.plumasnews.com/quincy-weather-summary-march-26-2021/#webpage","url":"https://www.plumasnews.com/quincy-weather-summary-march-26-2021/","name":"Quincy Weather Summary March 26, 2021 - Plumas News","isPartOf":{"@id":"https://www.plumasnews.com/#website"},"datePublished":"2021-03-27T00:48:23+00:00","dateModified":"2021-03-27T00:48:23+00:00","author":{"@id":"https://www.plumasnews.com/#/schema/person/7204148a5eb8fe94e7518dfb07c35175"},"breadcrumb":{"@id":"https://www.plumasnews.com/quincy-weather-summary-march-26-2021/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.plumasnews.com/quincy-weather-summary-march-26-2021/"]}]},{"@type":"BreadcrumbList","@id":"https://www.plumasnews.com/quincy-weather-summary-march-26-2021/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.plumasnews.com/","url":"https://www.plumasnews.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.plumasnews.com/quincy-weather-summary-march-26-2021/","url":"https://www.plumasnews.com/quincy-weather-summary-march-26-2021/","name":"Quincy Weather Summary March 26, 2021"}}]},{"@type":"Person","@id":"https://www.plumasnews.com/#/schema/person/7204148a5eb8fe94e7518dfb07c35175","name":"Eva","image":{"@type":"ImageObject","@id":"https://www.plumasnews.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/95f4175c9cc4ad2fc4d00ddff09c7168?s=96&d=mm&r=g","caption":"Eva"}}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Plumas News &raquo; Feed" href="https://www.plumasnews.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Plumas News &raquo; Comments Feed" href="https://www.plumasnews.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Plumas News &raquo; iCal Feed" href="https://www.plumasnews.com/events/?ical=1" /> <!-- plumasnews.com is managing ads with Advanced Ads --><script> advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}(); </script> <style id='wp-block-library-inline-css' type='text/css'> .has-text-align-justify{text-align:justify;} </style> <style id='colormag_style-inline-css' type='text/css'>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</style> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/add-to-any/addtoany.min.js' id='addtoany-js'></script> <script type='text/javascript' id='advanced-ads-advanced-js-js-extra'> /* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js' id='advanced-ads-advanced-js-js'></script> <script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'> /* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js' id='advanced_ads_pro/visitor_conditions-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/advanced-ds-pro/front.min.js' id='advanced-ds-pro/front-js'></script> <!--[if lte IE 8]> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/html5shiv.min.js' id='html5-js'></script> <![endif]--> <script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'> /* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"1","lazy_load":{"default_offset":200,"offsets":[]},"moveintohidden":""};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js' id='advanced-ads-pro/cache_busting-js'></script><link rel="https://api.w.org/" href="https://www.plumasnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.plumasnews.com/wp-json/wp/v2/posts/38040" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.plumasnews.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.plumasnews.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7" /><link rel='shortlink' href='https://www.plumasnews.com/?p=38040' /><link rel="alternate" type="application/json+oembed" href="https://www.plumasnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.plumasnews.com%2Fquincy-weather-summary-march-26-2021%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.plumasnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.plumasnews.com%2Fquincy-weather-summary-march-26-2021%2F&#038;format=xml" /> <script data-cfasync="false"> window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script"); </script> <!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-11530911-1"></script> <script> window.dataLayer = window.dataLayer || [];
 function gtag(){dataLayer.push(arguments);}
 gtag('js', new Date());  gtag('config', 'UA-11530911-1'); </script><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.plumasnews.com"><link rel="https://theeventscalendar.com/" href="https://www.plumasnews.com/wp-json/tribe/events/v1/" /><script type="text/javascript"> var advadsCfpQueue = [];
 var advadsCfpAd = function( adID ){
 if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
 }; </script> <style type="text/css" id="custom-background-css"> body.custom-background { background-color: #828282; } </style> <script type="text/javascript"> if ( 'undefined' == typeof advadsGATracking ) window.advadsGATracking = {}; </script><link rel="icon" href="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-32x32.jpg" sizes="32x32" /><link rel="icon" href="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-192x192.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-180x180.jpg" /><meta name="msapplication-TileImage" content="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-270x270.jpg" /> <style type="text/css" id="wp-custom-css"> .has-vivid-cyan-blue-color:hover {
 background-color: #1e73be;
 color: white;
}  .tg-footer-main-widget {
 width: 29.473684%;
 float: left;
 margin-right: 2.631579%;
}  .tg-footer-other-widgets {
 float: right;
 width: 67.894737%;
}  .myButton {
 background:linear-gradient(to bottom, #ffcd05 5%, #ff9900 100%);
 background-color:#ffcd05;
 border-radius:5px;
 border:1px solid #ffee00;
 display:inline-block;
 cursor:pointer;
 color:#0f0f0f;
 font-family:Arial;
 font-size:17px;
 font-weight:bold;
 padding:10px 31px;
 text-decoration:none;
}
.myButton:hover {
 background:linear-gradient(to bottom, #ff9900 5%, #ffcd05 100%);
 background-color:#ff9900;
}
.myButton:active {
 position:relative;
 top:1px;
} </style></head><body class="post-template-default single single-post postid-38040 single-format-standard custom-background wp-embed-responsive sfly_guest-author-post tribe-no-js right-sidebar box-layout better-responsive-menu aa-prefix-pluma-"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a><header id="masthead" class="site-header clearfix "><div id="header-text-nav-container" class="clearfix"><div class="news-bar"><div class="inner-wrap clearfix"><div class="date-in-header"> Friday, March 26, 2021</div><div class="breaking-news"> <strong class="breaking-news-latest">Latest:</strong><ul class="newsticker"><li> <a href="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/" title="Quincy Weather Summary March 26, 2021"> Quincy Weather Summary March 26, 2021 </a></li><li> <a href="https://www.plumasnews.com/plumas-national-forest-announces-recreation-plans/" title="Plumas National Forest announces recreation plans"> Plumas National Forest announces recreation plans </a></li><li> <a href="https://www.plumasnews.com/st-johns-announces-easter-services-schedule/" title="St. John&#8217;s announces Easter services schedule"> St. John&#8217;s announces Easter services schedule </a></li><li> <a href="https://www.plumasnews.com/plumas-continues-to-vaccinate-as-state-set-to-lower-age-requirements/" title="Plumas continues to vaccinate as state set to lower age requirements"> Plumas continues to vaccinate as state set to lower age requirements </a></li><li> <a href="https://www.plumasnews.com/ann-and-dick-joy/" title="Ann and Dick Joy"> Ann and Dick Joy </a></li></ul></div><div class="social-links clearfix"><ul><li><a href="https://www.facebook.com/plumasnews" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://www.twitter.com/plumasnews" target="_blank"><i class="fa fa-twitter"></i></a></li></ul></div><!-- .social-links --></div></div><div id="wp-custom-header" class="wp-custom-header"><div class="header-image-wrap"><img src="https://www.plumasnews.com/wp-content/uploads/2019/04/plumasnews-flag-chopped-1.jpg" class="header-image" width="1200" height="237" alt="Plumas News"></div></div><div class="inner-wrap"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class="screen-reader-text"><h3 id="site-title"> <a href="https://www.plumasnews.com/" title="Plumas News" rel="home">Plumas News</a></h3><p id="site-description"> Plumas County News</p><!-- #site-description --></div><!-- #header-text --></div><!-- #header-left-section --><div id="header-right-section"></div><!-- #header-right-section --></div><!-- #header-text-nav-wrap --></div><!-- .inner-wrap --><nav id="site-navigation" class="main-navigation clearfix" role="navigation"><div class="inner-wrap clearfix"><div class="home-icon"> <a href="https://www.plumasnews.com/"
 title="Plumas News"
 > <i class="fa fa-home"></i> </a></div><div class="search-random-icons-container"><div class="top-search-wrap"> <i class="fa fa-search search-top"></i><div class="search-form-top"><form action="https://www.plumasnews.com/" class="search-form searchform clearfix" method="get" role="search"><div class="search-wrap"> <input type="search"
 class="s field"
 name="s"
 value=""
 placeholder="Search"
 /> <button class="search-icon" type="submit"></button></div></form><!-- .searchform --></div></div></div><p class="menu-toggle"></p><div class="menu-primary-container"><ul id="menu-menu-1" class="menu"><li id="menu-item-381" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-381"><a href="https://www.plumasnews.com/category/news/">News</a></li><li id="menu-item-37016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37016"><a href="https://www.plumasnews.com/category/business-scene/">Business Scene</a></li><li id="menu-item-19111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19111"><a href="https://www.plumasnews.com/category/vitals/">Vitals</a><ul class="sub-menu"><li id="menu-item-19112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19112"><a href="https://www.plumasnews.com/category/vitals/births/">Births</a></li><li id="menu-item-19114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19114"><a href="https://www.plumasnews.com/category/vitals/obituaries/">Obituaries</a></li><li id="menu-item-19115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19115"><a href="https://www.plumasnews.com/category/vitals/marriage-licenses/">Marriage Licenses</a></li></ul></li><li id="menu-item-19091" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19091"><a href="https://www.plumasnews.com/category/law-order/">Law &amp; Order</a><ul class="sub-menu"><li id="menu-item-19092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19092"><a href="https://www.plumasnews.com/category/law-order/chp-report/">CHP Report</a></li><li id="menu-item-19093" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19093"><a href="https://www.plumasnews.com/category/law-order/criminal-case-update/">Criminal Case Update</a></li><li id="menu-item-34887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34887"><a href="https://www.plumasnews.com/category/law-order/sheriff-blotter/">Sheriff Blotter</a></li></ul></li><li id="menu-item-19095" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19095"><a href="https://www.plumasnews.com/category/opinion/">Opinion</a><ul class="sub-menu"><li id="menu-item-19096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19096"><a href="https://www.plumasnews.com/category/opinion/animal-tales/">Animal Tales</a></li><li id="menu-item-19098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19098"><a href="https://www.plumasnews.com/category/opinion/card-of-thanks/">Card of Thanks</a></li><li id="menu-item-19100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19100"><a href="https://www.plumasnews.com/category/opinion/community-green/">Community Green</a></li><li id="menu-item-19101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19101"><a href="https://www.plumasnews.com/category/opinion/editorial/">Editorial</a></li><li id="menu-item-19102" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19102"><a href="https://www.plumasnews.com/category/opinion/letters-to-the-editor/">Letter to the Editor</a></li><li id="menu-item-19105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19105"><a href="https://www.plumasnews.com/category/opinion/where-i-stand/">Where I Stand</a></li></ul></li><li id="menu-item-36595" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36595"><a href="#">Classifieds</a><ul class="sub-menu"><li id="menu-item-36596" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36596"><a href="https://www.lassennews.com/classifieds/">View Classifieds</a></li><li id="menu-item-36597" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36597"><a href="https://www.lassennews.com/classifieds/new-ad/">New Ad</a></li><li id="menu-item-36598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36598"><a href="https://www.lassennews.com/classifieds/classified-profile/">My Account</a></li></ul></li><li id="menu-item-19106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19106"><a href="https://www.plumasnews.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-19107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19107"><a href="https://www.plumasnews.com/category/sports/fish-bits/">Fish Bits</a></li><li id="menu-item-19108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19108"><a href="https://www.plumasnews.com/category/sports/golf-results/">Golf Results</a></li></ul></li><li id="menu-item-37747" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37747"><a href="/events">Events Calendar</a></li><li id="menu-item-4253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4253"><a>Publications</a><ul class="sub-menu"><li id="menu-item-35096" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35096"><a href="https://www.plumasnews.com/wp-content/uploads/2021/03/HCL-3.21.pdf">High Country Life</a></li><li id="menu-item-4252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4252"><a href="https://www.plumasnews.com/plumas-county-visitors-guide/">Plumas County Visitors Guide</a></li><li id="menu-item-4251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4251"><a href="https://www.plumasnews.com/plumas-county-dining-guide/">Plumas County Dining Guide</a></li><li id="menu-item-16212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16212"><a href="https://www.plumasnews.com/plumas-lassen-connection/">Plumas Lassen Connection</a></li><li id="menu-item-4250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4250"><a href="https://www.plumasnews.com/plumas-county-book-maps/">Plumas County Book of Maps</a></li><li id="menu-item-4248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4248"><a href="https://www.plumasnews.com/paying-tribute-150th-anniversary/">Paying Tribute to our 150th Anniversary</a></li><li id="menu-item-10461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10461"><a href="http://www.lassennews.com/lassen-county-visitors-guide/">Lassen County Visitors Guide</a></li><li id="menu-item-16213" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16213"><a href="https://www.lassennews.com/wp-content/uploads/2021/01/LMB20x.pdf">Lassen County Book of Maps</a></li><li id="menu-item-4744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4744"><a href="http://www.lassennews.com">Lassen News</a></li></ul></li><li id="menu-item-29097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29097"><a href="https://www.plumasnews.com/category/public-notices/">Public Notices</a><ul class="sub-menu"><li id="menu-item-34783" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34783"><a href="https://www.plumasnews.com/category/public-notices/">Plumas County Public Notices</a></li><li id="menu-item-33677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33677"><a href="https://www.lassennews.com/category/public-notices/lassen-county-public-notices/">Lassen County Public Notices</a></li><li id="menu-item-29099" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29099"><a href="http://www.capublicnotice.com/">Statewide Public Notices</a></li></ul></li><li id="menu-item-36547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36547"><a href="#">Weather</a><ul class="sub-menu"><li id="menu-item-36545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36545"><a href="https://www.plumasnews.com/weather-road-conditions/">Weather &#038; Road Conditions</a></li><li id="menu-item-36546" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-36546"><a href="https://www.plumasnews.com/category/weekly-temperatures/">Weekly Temperatures</a></li></ul></li><li id="menu-item-19151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-19151"><a href="https://www.plumasnews.com/contact-2/">Contact</a><ul class="sub-menu"><li id="menu-item-30459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30459"><a href="https://www.plumasnews.com/submit-to-plumas-news/">Submit to Plumas News</a></li></ul></li><li id="menu-item-32791" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32791"><a href="https://www.plumasnews.com/subscribe/">Subscribe</a></li><li id="menu-item-34004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34004"><a href="https://www.plumasnews.com/donate/">Donate</a></li></ul></div></div></nav></div><!-- #header-text-nav-container --></header><div id="main" class="clearfix"><div class="inner-wrap clearfix"><div class="front-page-top-section clearfix"><div class="widget_slider_area"><section id="text-7" class="widget widget_text clearfix"><div class="textwidget"><div class="pluma-142cf89410980d0f8ae7dbd85cb99c9b pluma-banner-left" id="pluma-142cf89410980d0f8ae7dbd85cb99c9b"></div></div></section></div><div class="widget_beside_slider"><section id="text-6" class="widget widget_text clearfix"><div class="textwidget"><div class="pluma-3e957faf52609cea0ee3f24301b378a7 pluma-banner-right" id="pluma-3e957faf52609cea0ee3f24301b378a7"></div></div></section></div></div><div id="primary"><div id="content" class="clearfix"><article id="post-38040" class="post-38040 post type-post status-publish format-standard hentry category-weekly-temperatures"><div class="caption-content"></div><div class="article-content clearfix"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.plumasnews.com/category/weekly-temperatures/"  rel="category tag">Weekly Temperatures</a>&nbsp;</span></div><header class="entry-header"><h1 class="entry-title"> Quincy Weather Summary March 26, 2021</h1></header><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/" title="5:48 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2021-03-26T17:48:23-07:00">March 26, 2021</time></a></span> <span class="byline"> <span class="author vcard"> <i class="fa fa-user"></i> <a class="url fn n"
 href=""
 title="Submitted"
 > Submitted </a> </span> </span></div><div class="entry-content clearfix"><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_26 addtoany_list" data-a2a-url="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/" data-a2a-title="Quincy Weather Summary March 26, 2021"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.plumasnews.com%2Fquincy-weather-summary-march-26-2021%2F&amp;linkname=Quincy%20Weather%20Summary%20March%2026%2C%202021" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.plumasnews.com%2Fquincy-weather-summary-march-26-2021%2F&amp;linkname=Quincy%20Weather%20Summary%20March%2026%2C%202021" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.plumasnews.com%2Fquincy-weather-summary-march-26-2021%2F&amp;linkname=Quincy%20Weather%20Summary%20March%2026%2C%202021" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><p><strong>Quincy Weather</strong></p><p><strong>March 19 – March 26, 2021</strong></p><p><strong>Compiled By Ron Trumbo</strong></p><p><strong> </strong><strong>Date            Hi            Lo            Rain – Snow (Inches)</strong></p><p>March 19&#8230;&#8230;&#8230;.. 48&#8230;&#8230;&#8230;.. 38&#8230;&#8230;&#8230;.. 0.09</p><p>March 20&#8230;&#8230;&#8230;.. 50&#8230;&#8230;&#8230;.. 33&#8230;&#8230;&#8230;.. 0.26 &#8211; trace</p><p>March 21&#8230;&#8230;&#8230;.. 57&#8230;&#8230;&#8230;.. 32&#8230;&#8230;&#8230;.. 0.02</p><p>March 22&#8230;&#8230;&#8230;.. 56&#8230;&#8230;&#8230;.. 32&#8230;&#8230;&#8230;.. 0.0</p><p>March 23&#8230;&#8230;&#8230;.. 52&#8230;&#8230;&#8230;.. 32&#8230;&#8230;&#8230;.. 0.07</p><p>March 24&#8230;&#8230;&#8230;.. 60&#8230;&#8230;&#8230;.. 25&#8230;&#8230;&#8230;.. 0.0</p><p>March 25&#8230;&#8230;&#8230;.. 57&#8230;&#8230;&#8230;.. 26&#8230;&#8230;&#8230;.. 0.0</p><p>March 26&#8230;&#8230;&#8230;.. &#8211;&#8230;&#8230;&#8230;.. 25&#8230;&#8230;&#8230;.. 0.0</p><p><strong>Season Totals: (Since July 1, 2020)</strong></p><p>Snow 31 inches</p><p>Precipitation: 19.03 inches</p></div></div></article></div><!-- #content --><ul class="default-wp-page clearfix"><li class="previous"><a href="https://www.plumasnews.com/plumas-national-forest-announces-recreation-plans/" rel="prev"><span class="meta-nav">&larr;</span> Plumas National Forest announces recreation plans</a></li><li class="next"></li></ul> <!--BEGIN More News Section--><h3 id="more-news-h3">More News</h3><hr id="more-news-hr"> <style>.wp-show-posts-columns#wpsp-28237 {margin-left: -2em; }.wp-show-posts-columns#wpsp-28237 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-28237" class=" wp-show-posts-columns wp-show-posts" style=""><article class=" wp-show-posts-single post-38038 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/plumas-national-forest-announces-recreation-plans/" rel="bookmark">Plumas National Forest announces recreation plans</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/plumas-national-forest-announces-recreation-plans/" title="3:31 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-26T15:31:39-07:00" itemprop="datePublished">March 26, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>More campsites across the Plumas National Forest within the Feather River Canyon, Bucks Lake, Lake&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Plumas National Forest announces recreation plans" class="more-link" href="https://www.plumasnews.com/plumas-national-forest-announces-recreation-plans/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-38033 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/st-johns-announces-easter-services-schedule/" rel="bookmark">St. John&#8217;s announces Easter services schedule</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/st-johns-announces-easter-services-schedule/" title="2:17 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-26T14:17:53-07:00" itemprop="datePublished">March 26, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>St. John&#8217;s Catholic Church in Quincy and St. Anthony&#8217;s Catholic Church in Greenville have announced&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="St. John&#8217;s announces Easter services schedule" class="more-link" href="https://www.plumasnews.com/st-johns-announces-easter-services-schedule/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-38026 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/plumas-continues-to-vaccinate-as-state-set-to-lower-age-requirements/" rel="bookmark">Plumas continues to vaccinate as state set to lower age requirements</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/plumas-continues-to-vaccinate-as-state-set-to-lower-age-requirements/" title="1:24 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-26T13:24:58-07:00" itemprop="datePublished">March 26, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Debra Moore <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1571787a7a6770556579607874667b7062663b767a78">[email&#160;protected]</a> Plumas County has administered at least one dose of vaccine to&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Plumas continues to vaccinate as state set to lower age requirements" class="more-link" href="https://www.plumasnews.com/plumas-continues-to-vaccinate-as-state-set-to-lower-age-requirements/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-38018 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/fire-training-event-centered-at-frc-friday-sunday/" rel="bookmark">Fire training event centered at FRC Friday-Sunday</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/fire-training-event-centered-at-frc-friday-sunday/" title="7:00 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-26T07:00:54-07:00" itemprop="datePublished">March 26, 2021</time><time class="wp-show-posts-updated" datetime="2021-03-25T16:46:36-07:00" itemprop="dateModified">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Just a reminder that a prescribed fire training event is scheduled today, March 26, through&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Fire training event centered at FRC Friday-Sunday" class="more-link" href="https://www.plumasnews.com/fire-training-event-centered-at-frc-friday-sunday/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37994 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/march-25-plumas-announces-3-new-cases/" rel="bookmark">March 25: Plumas announces 3 new cases</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/march-25-plumas-announces-3-new-cases/" title="6:12 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T18:12:46-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Plumas County Public Health Agency announced this evening, March 25, that there are 3&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="March 25: Plumas announces 3 new cases" class="more-link" href="https://www.plumasnews.com/march-25-plumas-announces-3-new-cases/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-38016 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/portola-city-council-meets-keeps-covid-measures-in-place/" rel="bookmark">Portola City council meets; keeps Covid measures in place</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/portola-city-council-meets-keeps-covid-measures-in-place/" title="3:32 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T15:32:36-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Lauren Westmoreland <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="eb879c8e989f8684998e878a858fab9b879e868a98858e9c98c5888486">[email&#160;protected]</a> The City of Portola held a regularly scheduled meeting on the&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Portola City council meets; keeps Covid measures in place" class="more-link" href="https://www.plumasnews.com/portola-city-council-meets-keeps-covid-measures-in-place/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-38012 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/city-council-approves-fee-increases-for-curbside-recycling-more/" rel="bookmark">City council approves fee increases for curbside recycling, more</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/city-council-approves-fee-increases-for-curbside-recycling-more/" title="3:25 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T15:25:03-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Lauren Westmoreland <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="167a617365627b7964737a77787256667a637b7765787361653875797b">[email&#160;protected]</a> Intermountain Disposal Company (IMD) asked the Portola City Council to approve&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="City council approves fee increases for curbside recycling, more" class="more-link" href="https://www.plumasnews.com/city-council-approves-fee-increases-for-curbside-recycling-more/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-38007 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/using-art-to-explore-post-fire-ecology-event-this-saturday/" rel="bookmark">Using art to explore post-fire ecology; event this Saturday</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/using-art-to-explore-post-fire-ecology-event-this-saturday/" title="1:05 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T13:05:55-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>On Saturday, March 27, from 11 a.m. to 2 p.m. the Plumas County Fire Safe&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Using art to explore post-fire ecology; event this Saturday" class="more-link" href="https://www.plumasnews.com/using-art-to-explore-post-fire-ecology-event-this-saturday/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-38010 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/public-health-wrapping-up-vaccine-event/" rel="bookmark">Public Health wrapping up vaccine event</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/public-health-wrapping-up-vaccine-event/" title="12:47 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T12:47:50-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Plumas County Public Health is wrapping up today&#8217;s vaccine clinic at the fairgrounds in Quincy&#8230;.</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Public Health wrapping up vaccine event" class="more-link" href="https://www.plumasnews.com/public-health-wrapping-up-vaccine-event/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37953 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/new-power-pole-going-up-in-east-quincy/" rel="bookmark">New power pole going up in East Quincy</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/new-power-pole-going-up-in-east-quincy/" title="10:44 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T10:44:38-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>An East Quincy resident contacted Plumas News to ask about what was happening in her&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="New power pole going up in East Quincy" class="more-link" href="https://www.plumasnews.com/new-power-pole-going-up-in-east-quincy/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37996 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/doses-still-available-at-fairgrounds/" rel="bookmark">Doses still available at fairgrounds</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/doses-still-available-at-fairgrounds/" title="10:20 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T10:20:28-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Public Health announced that as of 10 a.m. today, March 25, there are still 100&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Doses still available at fairgrounds" class="more-link" href="https://www.plumasnews.com/doses-still-available-at-fairgrounds/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37988 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/reminder-vaccine-clinic-today-150-walk-in-slots-available/" rel="bookmark">Reminder: Vaccine clinic today; 150 walk-in slots available</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/reminder-vaccine-clinic-today-150-walk-in-slots-available/" title="8:29 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-25T08:29:38-07:00" itemprop="datePublished">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Plumas County Public Health is holding a vaccination clinic at the fairgrounds in Quincy today&#8230;.</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Reminder: Vaccine clinic today; 150 walk-in slots available" class="more-link" href="https://www.plumasnews.com/reminder-vaccine-clinic-today-150-walk-in-slots-available/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37958 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/grand-jury-members-sought-summons-will-be-sent-next-week/" rel="bookmark">Grand jury members sought; summons will be sent next week</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/grand-jury-members-sought-summons-will-be-sent-next-week/" title="2:11 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-24T14:11:55-07:00" itemprop="datePublished">March 24, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Superior Court in Plumas County is preparing to select a new Civil Grand Jury,&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Grand jury members sought; summons will be sent next week" class="more-link" href="https://www.plumasnews.com/grand-jury-members-sought-summons-will-be-sent-next-week/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37960 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/quincy-rotary-secures-grant-to-aid-elementary-schools/" rel="bookmark">Quincy Rotary secures grant to aid elementary schools; donations also welcome</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/quincy-rotary-secures-grant-to-aid-elementary-schools/" title="11:23 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-24T11:23:08-07:00" itemprop="datePublished">March 24, 2021</time><time class="wp-show-posts-updated" datetime="2021-03-25T05:24:40-07:00" itemprop="dateModified">March 25, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Quincy Rotary Club has received a $3,300 matching grant from the service club’s District&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Quincy Rotary secures grant to aid elementary schools; donations also welcome" class="more-link" href="https://www.plumasnews.com/quincy-rotary-secures-grant-to-aid-elementary-schools/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37963 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/both-irs-and-state-income-tax-deadlines-extended/" rel="bookmark">Both IRS and state income tax deadlines extended</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/both-irs-and-state-income-tax-deadlines-extended/" title="11:14 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-24T11:14:26-07:00" itemprop="datePublished">March 24, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The U.S. Treasury Department and the IRS extended the federal income tax filing date from&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Both IRS and state income tax deadlines extended" class="more-link" href="https://www.plumasnews.com/both-irs-and-state-income-tax-deadlines-extended/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37947 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/former-plumas-resident-shares-covid-experience-and-says-get-the-vaccine/" rel="bookmark">Former Plumas resident shares COVID experience and says &#8216;get the vaccine&#8217;</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/former-plumas-resident-shares-covid-experience-and-says-get-the-vaccine/" title="9:11 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-24T09:11:08-07:00" itemprop="datePublished">March 24, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Victoria Metcalf <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e89e858d9c8b89848ea898849d85899b868d9f9bc68b8785">[email&#160;protected]</a> &nbsp; Imagine lying on your sofa, fighting for every breath. And&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Former Plumas resident shares COVID experience and says &#8216;get the vaccine&#8217;" class="more-link" href="https://www.plumasnews.com/former-plumas-resident-shares-covid-experience-and-says-get-the-vaccine/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37929 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/update-on-california-small-business-covid-19-relief-grant-program/" rel="bookmark">Update on California small business Covid-19 relief grant program</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/update-on-california-small-business-covid-19-relief-grant-program/" title="6:22 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-23T18:22:40-07:00" itemprop="datePublished">March 23, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The California Office of the Small Business Advocate (CalOSBA) has released updates for the California&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Update on California small business Covid-19 relief grant program" class="more-link" href="https://www.plumasnews.com/update-on-california-small-business-covid-19-relief-grant-program/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37901 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/vaccination-options-this-week-walk-ins-possible-thursday-at-the-fairgrounds/" rel="bookmark">Vaccination options this week; walk-ins possible Thursday at the fairgrounds</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/vaccination-options-this-week-walk-ins-possible-thursday-at-the-fairgrounds/" title="1:20 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-23T13:20:46-07:00" itemprop="datePublished">March 23, 2021</time><time class="wp-show-posts-updated" datetime="2021-03-26T09:39:42-07:00" itemprop="dateModified">March 26, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Debra Moore <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="1d797072726f785d6d7168707c6e73786a6e337e7270">[email&#160;protected]</a> Following the success of Saturday&#8217;s clinic that administered 800 doses, the&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Vaccination options this week; walk-ins possible Thursday at the fairgrounds" class="more-link" href="https://www.plumasnews.com/vaccination-options-this-week-walk-ins-possible-thursday-at-the-fairgrounds/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37910 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/plumas-charters-cte-program-expands-with-credentials-pathway-development/" rel="bookmark">Plumas Charter’s CTE program expands with credentials, pathway development</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/plumas-charters-cte-program-expands-with-credentials-pathway-development/" title="12:09 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-23T12:09:20-07:00" itemprop="datePublished">March 23, 2021</time><time class="wp-show-posts-updated" datetime="2021-03-26T09:40:08-07:00" itemprop="dateModified">March 26, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Ingrid Burke <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="2f464d5a5d444a6f5f435a424e5c4c474e5d5b4a5d5c4c4740404301405d48">[email&#160;protected]</a> With the funds provided by two back-to-back grant awards, Plumas Charter&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Plumas Charter’s CTE program expands with credentials, pathway development" class="more-link" href="https://www.plumasnews.com/plumas-charters-cte-program-expands-with-credentials-pathway-development/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37899 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/plumas-county-bar-association-offers-scholarships/" rel="bookmark">Plumas County Bar Association offers scholarships</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/plumas-county-bar-association-offers-scholarships/" title="11:17 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-23T11:17:13-07:00" itemprop="datePublished">March 23, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Again this year, the Plumas County Bar Association will be awarding a $1000 scholarship to&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Plumas County Bar Association offers scholarships" class="more-link" href="https://www.plumasnews.com/plumas-county-bar-association-offers-scholarships/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-37892 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/adult-softball-teams-forming-now-2/" rel="bookmark">Adult softball teams forming now</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/adult-softball-teams-forming-now-2/" title="11:01 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-03-23T11:01:50-07:00" itemprop="datePublished">March 23, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Central Plumas Recreation and Park District has started its preseason planning and sign-ups for&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Adult softball teams forming now" class="more-link" href="https://www.plumasnews.com/adult-softball-teams-forming-now-2/">Read More</a></div></div><!-- wp-show-posts-inner --></article><div class="wpsp-clear"></div></section><!-- .wp-show-posts --> <!--END More News Section--></div><!-- #primary --><div id="secondary"><aside id="custom_html-2" class="widget_text extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_custom_html clearfix"><h3 class="widget-title"><span>I want to support plumasnews.com</span></h3><div class="textwidget custom-html-widget"><a href="/donate" class="myButton">Click Here</a></div></aside><aside id="blog_subscription-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_blog_subscription jetpack_subscription_widget clearfix"><h3 class="widget-title"><span>Subscribe via Email</span></h3><form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2"><div id="subscribe-text"><p>Enter your email address to subscribe to Plumas News and receive notifications of new posts by email.</p></div><p id="subscribe-email"> <label id="jetpack-subscribe-label"
 class="screen-reader-text"
 for="subscribe-field-blog_subscription-2"> Email Address </label> <input type="email" name="email" required="required"
 value=""
 id="subscribe-field-blog_subscription-2"
 placeholder="Email Address"
 /></p><p id="subscribe-submit"> <input type="hidden" name="action" value="subscribe"/> <input type="hidden" name="source" value="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/"/> <input type="hidden" name="sub-type" value="widget"/> <input type="hidden" name="redirect_fragment" value="blog_subscription-2"/> <button type="submit"
 name="jetpack_subscriptions_widget"
 > Subscribe </button></p></form></aside><aside class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget pluma-widget clearfix"><div class="pluma-101b4fa229ba733dec3e20c9595a711b" id="pluma-101b4fa229ba733dec3e20c9595a711b"></div></aside><aside class="extendedwopts-show extendedwopts-desktop widget pluma-widget clearfix"><div class="pluma-18895e16171338fd2621fe94ec2cbd2d" id="pluma-18895e16171338fd2621fe94ec2cbd2d"></div></aside><aside id="text-5" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_text clearfix"><div class="textwidget"><div class="pluma-be8bc1b13928aeda63d3b4bb573ddfa8 pluma-sidebar-desktop-placement" id="pluma-be8bc1b13928aeda63d3b4bb573ddfa8"></div></div></aside></div></div><!-- .inner-wrap --><div class="front-page-top-section clearfix"><div class="widget_slider_area"><section id="text-7" class="widget widget_text clearfix"><div class="textwidget"><div class="pluma-0efb9f7a23fa2ba3da1b00f5a8aed2a2 pluma-banner-left" id="pluma-0efb9f7a23fa2ba3da1b00f5a8aed2a2"></div></div></section></div><div class="widget_beside_slider"><section id="text-6" class="widget widget_text clearfix"><div class="textwidget"><div class="pluma-3684b8f8d515fb012142fcda5aeef901 pluma-banner-right" id="pluma-3684b8f8d515fb012142fcda5aeef901"></div></div></section></div></div></div><!-- #main --><div class="advertisement_above_footer"><div class="inner-wrap"><aside id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget clearfix"><div
 class="hide-on-button negative"
 data-hide-timeout="30"
 data-consent-expiration="180"
 id="eu-cookie-law"
><form method="post"> <input type="submit" value="Close and accept" class="accept" /></form> Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br /> To find out more, including how to control cookies, see here: <a href="https://www.plumasnews.com/privacy-policy-2/" rel=""> Cookie Policy </a></div></aside></div></div><footer id="colophon" class="clearfix "><div class="footer-widgets-wrapper"><div class="inner-wrap"><div class="footer-widgets-area clearfix"><div class="tg-footer-main-widget"><div class="tg-first-footer-widget"><aside id="blog_subscription-3" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_blog_subscription jetpack_subscription_widget clearfix"><h3 class="widget-title"><span>Subscribe via Email</span></h3><form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3"><div id="subscribe-text"><p>Enter your email address to subscribe to Plumas News and receive notifications of new posts by email.</p></div><p id="subscribe-email"> <label id="jetpack-subscribe-label"
 class="screen-reader-text"
 for="subscribe-field-blog_subscription-3"> Email Address </label> <input type="email" name="email" required="required"
 value=""
 id="subscribe-field-blog_subscription-3"
 placeholder="Email Address"
 /></p><p id="subscribe-submit"> <input type="hidden" name="action" value="subscribe"/> <input type="hidden" name="source" value="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/"/> <input type="hidden" name="sub-type" value="widget"/> <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/> <button type="submit"
 name="jetpack_subscriptions_widget"
 > Subscribe </button></p></form></aside></div></div><div class="tg-footer-other-widgets"><div class="tg-second-footer-widget"><aside id="pages-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_pages clearfix"><h3 class="widget-title"><span>Pages</span></h3><ul><li class="page_item page-item-12086"><a href="https://www.plumasnews.com/contact-2/">Contact</a></li><li class="page_item page-item-33992"><a href="https://www.plumasnews.com/donate/">Donate</a></li><li class="page_item page-item-4246"><a href="https://www.plumasnews.com/paying-tribute-150th-anniversary/">Paying Tribute to our 150th Anniversary</a></li><li class="page_item page-item-4241"><a href="https://www.plumasnews.com/plumas-county-book-maps/">Plumas County Book of Maps</a></li><li class="page_item page-item-4239"><a href="https://www.plumasnews.com/plumas-county-dining-guide/">Plumas County Dining Guide</a></li><li class="page_item page-item-4237"><a href="https://www.plumasnews.com/plumas-county-visitors-guide/">Plumas County Visitors Guide</a></li><li class="page_item page-item-4244"><a href="https://www.plumasnews.com/plumas-lassen-connection/">Plumas-Lassen Connection</a></li><li class="page_item page-item-10888"><a href="https://www.plumasnews.com/privacy-policy-2/">Privacy Policy</a></li><li class="page_item page-item-30457"><a href="https://www.plumasnews.com/submit-to-plumas-news/">Submit to Plumas News</a></li><li class="page_item page-item-266"><a href="https://www.plumasnews.com/weather-road-conditions/">Weather &#038; Road Conditions</a></li></ul></aside></div><div class="tg-third-footer-widget"><aside id="categories-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_categories clearfix"><h3 class="widget-title"><span>Categories</span></h3><form action="https://www.plumasnews.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' ><option value='-1'>Select Category</option><option class="level-0" value="3">Business Scene</option><option class="level-0" value="86">Events</option><option class="level-0" value="70">Highlighted</option><option class="level-0" value="52">Law &amp; Order</option><option class="level-1" value="53">&nbsp;&nbsp;&nbsp;CHP Report</option><option class="level-1" value="55">&nbsp;&nbsp;&nbsp;Criminal Case Update</option><option class="level-1" value="54">&nbsp;&nbsp;&nbsp;Sheriff Blotter</option><option class="level-0" value="5">News</option><option class="level-1" value="81">&nbsp;&nbsp;&nbsp;Newsmakers</option><option class="level-0" value="7">Opinion</option><option class="level-1" value="49">&nbsp;&nbsp;&nbsp;Animal Tales</option><option class="level-1" value="51">&nbsp;&nbsp;&nbsp;C-Force</option><option class="level-1" value="50">&nbsp;&nbsp;&nbsp;Card of Thanks</option><option class="level-1" value="44">&nbsp;&nbsp;&nbsp;Commander&#8217;s Corner</option><option class="level-1" value="47">&nbsp;&nbsp;&nbsp;Community Green</option><option class="level-1" value="14">&nbsp;&nbsp;&nbsp;Editorial</option><option class="level-1" value="48">&nbsp;&nbsp;&nbsp;Letter to the Editor</option><option class="level-1" value="17">&nbsp;&nbsp;&nbsp;My Turn</option><option class="level-1" value="67">&nbsp;&nbsp;&nbsp;Plumas County Volunteers</option><option class="level-1" value="9">&nbsp;&nbsp;&nbsp;Remember When</option><option class="level-1" value="39">&nbsp;&nbsp;&nbsp;Where I Stand</option><option class="level-0" value="8">Public Notices</option><option class="level-0" value="10">Sports</option><option class="level-1" value="57">&nbsp;&nbsp;&nbsp;Fish Bits</option><option class="level-1" value="56">&nbsp;&nbsp;&nbsp;Golf Results</option><option class="level-1" value="58">&nbsp;&nbsp;&nbsp;Graeagle Peggers</option><option class="level-0" value="2">Vitals</option><option class="level-1" value="11">&nbsp;&nbsp;&nbsp;Births</option><option class="level-1" value="46">&nbsp;&nbsp;&nbsp;Marriage Licenses</option><option class="level-1" value="6">&nbsp;&nbsp;&nbsp;Obituaries</option><option class="level-0" value="80">Weekly Temperatures</option> </select></form> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript"> /* <![CDATA[ */
(function() {
 var dropdown = document.getElementById( "cat" );
 function onCatChange() {
 if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
 dropdown.parentNode.submit();
 }
 }
 dropdown.onchange = onCatChange;
})();
/* ]]> */ </script></aside></div><div class="tg-fourth-footer-widget"><aside id="recent-posts-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_recent_entries clearfix"><h3 class="widget-title"><span>Recent Posts</span></h3><ul><li> <a href="https://www.plumasnews.com/quincy-weather-summary-march-26-2021/" aria-current="page">Quincy Weather Summary March 26, 2021</a></li><li> <a href="https://www.plumasnews.com/plumas-national-forest-announces-recreation-plans/">Plumas National Forest announces recreation plans</a></li><li> <a href="https://www.plumasnews.com/st-johns-announces-easter-services-schedule/">St. John&#8217;s announces Easter services schedule</a></li><li> <a href="https://www.plumasnews.com/plumas-continues-to-vaccinate-as-state-set-to-lower-age-requirements/">Plumas continues to vaccinate as state set to lower age requirements</a></li><li> <a href="https://www.plumasnews.com/ann-and-dick-joy/">Ann and Dick Joy</a></li></ul></aside></div></div></div></div></div><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"><div class="footer-socket-right-section"><div class="social-links clearfix"><ul><li><a href="https://www.facebook.com/plumasnews" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://www.twitter.com/plumasnews" target="_blank"><i class="fa fa-twitter"></i></a></li></ul></div><!-- .social-links --></div><div class="footer-socket-left-section"><div class="copyright">Copyright &copy; 2021 <a href="https://www.plumasnews.com/" title="Plumas News" ><span>Plumas News</span></a>. All rights reserved.<br>Theme: <a href="https://themegrill.com/themes/colormag" target="_blank" title="ColorMag" rel="nofollow"><span>ColorMag</span></a> by ThemeGrill. Powered by <a href="https://wordpress.org" target="_blank" title="WordPress" rel="nofollow"><span>WordPress</span></a>.</div></div></div><!-- .footer-socket-area --></div><!-- .inner-wrap --></div><!-- .footer-socket-wrapper --></footer><!-- #colophon --> <a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a></div><!-- #page --> <script> ( function ( body ) {
 'use strict';
 body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
 } )( document.body ); </script> <script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script> <script type='text/javascript' id='wp-polyfill-js-after'> ( 'fetch' in window ) || document.write( '<script src="https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://www.plumasnews.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js"></scr' + 'ipt>' ); </script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/dist/hooks.min.js' id='wp-hooks-js'></script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/dist/i18n.min.js' id='wp-i18n-js'></script> <script type='text/javascript' id='wp-i18n-js-after'> wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } ); </script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/dist/vendor/lodash.min.js' id='lodash-js'></script> <script type='text/javascript' id='lodash-js-after'> window.lodash = _.noConflict(); </script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/dist/url.min.js' id='wp-url-js'></script> <script type='text/javascript' id='wp-api-fetch-js-translations'> ( function( domain, translations ) {
 var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
 localeData[""].domain = domain;
 wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } ); </script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/dist/api-fetch.min.js' id='wp-api-fetch-js'></script> <script type='text/javascript' id='wp-api-fetch-js-after'> wp.apiFetch.use( wp.apiFetch.createRootURLMiddleware( "https://www.plumasnews.com/wp-json/" ) );
wp.apiFetch.nonceMiddleware = wp.apiFetch.createNonceMiddleware( "418f15e214" );
wp.apiFetch.use( wp.apiFetch.nonceMiddleware );
wp.apiFetch.use( wp.apiFetch.mediaUploadMiddleware );
wp.apiFetch.nonceEndpoint = "https://www.plumasnews.com/wp-admin/admin-ajax.php?action=rest-nonce"; </script> <script type='text/javascript' id='contact-form-7-js-extra'> /* <![CDATA[ */
var wpcf7 = [];
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/contact-form-7.min.js' id='contact-form-7-js'></script> <script defer type='text/javascript' id='google-invisible-recaptcha-js-before'> var renderInvisibleReCaptcha = function() {  for (var i = 0; i < document.forms.length; ++i) {
 var form = document.forms[i];
 var holder = form.querySelector('.inv-recaptcha-holder');  if (null === holder) continue;
 holder.innerHTML = '';  (function(frm){
 var cf7SubmitElm = frm.querySelector('.wpcf7-submit');
 var holderId = grecaptcha.render(holder,{
 'sitekey': '6LdbLyIUAAAAANyBnSa49kZ4yVSmvqwoCI2GAJPi', 'size': 'invisible', 'badge' : 'inline',
 'callback' : function (recaptchaToken) {
 if((null !== cf7SubmitElm) && (typeof jQuery != 'undefined')){jQuery(frm).submit();grecaptcha.reset(holderId);return;}
 HTMLFormElement.prototype.submit.call(frm);
 },
 'expired-callback' : function(){grecaptcha.reset(holderId);}
 });  if(null !== cf7SubmitElm && (typeof jQuery != 'undefined') ){
 jQuery(cf7SubmitElm).off('click').on('click', function(clickEvt){
 clickEvt.preventDefault();
 grecaptcha.execute(holderId);
 });
 }
 else
 {
 frm.onsubmit = function (evt){evt.preventDefault();grecaptcha.execute(holderId);};
 }  })(form);
 }
};
</script> <script defer type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?onload=renderInvisibleReCaptcha#038;render=explicit&#038;siteground-async=1' id='google-invisible-recaptcha-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/jquery.bxslider.min.js' id='colormag-bxslider-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/news-ticker/jquery.newsTicker.min.js' id='colormag-news-ticker-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/magnific-popup/jquery.magnific-popup.min.js' id='colormag-featured-image-popup-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/navigation.min.js' id='colormag-navigation-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/fitvids/jquery.fitvids.min.js' id='colormag-fitvids-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/skip-link-focus-fix.min.js' id='colormag-skip-link-focus-fix-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/colormag-custom.min.js' id='colormag-custom-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script> <script type='text/javascript' id='advadsTrackingHandle-js-extra'> /* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":"ga","blogId":"1"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/advadsTrackingHandle.min.js' id='advadsTrackingHandle-js'></script> <script type='text/javascript' id='advadsTrackingGAFront-js-extra'> /* <![CDATA[ */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/advadsTrackingGAFront.min.js' id='advadsTrackingGAFront-js'></script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script> <script type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/wp-show-posts/js/jquery.matchHeight.js' id='wpsp-matchHeight-js'></script><div class="pluma-4123d8c23670cfd8221bf70b08d06c19 pluma-custom-placement" id="pluma-4123d8c23670cfd8221bf70b08d06c19"></div><script>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</script><script type="text/javascript">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</script><script type="text/javascript"> if ( 'undefined' == typeof window.advadsGATracking ) window.advadsGATracking = {};
 advadsGATracking.postContext = {"postID":38040,"postSlug":"quincy-weather-summary-march-26-2021","cats":"weekly-temperatures"}; </script></body></html>