<!DOCTYPE html><html lang="en-US"><head><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11" /> <!-- Optimized by SG Optimizer plugin version - 5.7.12 --> <!-- This site is optimized with the Yoast SEO plugin v15.6.2 - https://yoast.com/wordpress/plugins/seo/ --><title>Seneca collecting Valentines for its senior nursing residents - Plumas News</title><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin/><style type="text/css">@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0e.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 600;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOUuhs.ttf) format('truetype');
} </style><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0bf8pkAg.woff2" crossorigin/><link rel="preload" as="font" href="https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOUuhpKKSTjw.woff2" crossorigin/><link rel="preload" as="font" href="https://www.plumasnews.com/wp-content/themes/colormag/fontawesome/fonts/fontawesome-webfont.woff2?v=4.7.0" crossorigin/><link rel="stylesheet" id="siteground-optimizer-combined-css-b1fa0389124aa2119901cd773b48914f" href="https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-b1fa0389124aa2119901cd773b48914f.css" media="all" /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Seneca collecting Valentines for its senior nursing residents - Plumas News" /><meta property="og:description" content="The Seneca Healthcare District is collecting Valentine&#8217;s Day cards for its senior nursing residents. &#8220;It has been a challenging year" /><meta property="og:url" content="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/" /><meta property="og:site_name" content="Plumas News" /><meta property="article:publisher" content="http://www.facebook.com/Plumasnews/" /><meta property="article:published_time" content="2021-02-05T22:21:43+00:00" /><meta property="og:image" content="https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-scaled.jpg" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@plumasnews" /><meta name="twitter:site" content="@plumasnews" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Editor"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="1 minute"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.plumasnews.com/#website","url":"https://www.plumasnews.com/","name":"Plumas News","description":"Plumas County News","potentialAction":[{"@type":"SearchAction","target":"https://www.plumasnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/#primaryimage","inLanguage":"en-US","url":"https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-scaled.jpg","width":1810,"height":2560},{"@type":"WebPage","@id":"https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/#webpage","url":"https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/","name":"Seneca collecting Valentines for its senior nursing residents - Plumas News","isPartOf":{"@id":"https://www.plumasnews.com/#website"},"primaryImageOfPage":{"@id":"https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/#primaryimage"},"datePublished":"2021-02-05T22:21:43+00:00","dateModified":"2021-02-05T22:21:43+00:00","author":{"@id":"https://www.plumasnews.com/#/schema/person/78f3dfdd65d3c93a09c75a65a4e82bb8"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/"]}]},{"@type":"Person","@id":"https://www.plumasnews.com/#/schema/person/78f3dfdd65d3c93a09c75a65a4e82bb8","name":"Editor","image":{"@type":"ImageObject","@id":"https://www.plumasnews.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/835ae976839f3e065e763507ceef261f?s=96&d=mm&r=g","caption":"Editor"}}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Plumas News &raquo; Feed" href="https://www.plumasnews.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Plumas News &raquo; Comments Feed" href="https://www.plumasnews.com/comments/feed/" /> <!-- plumasnews.com is managing ads with Advanced Ads --><script> advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}(); </script> <style id='wp-block-library-inline-css' type='text/css'> .has-text-align-justify{text-align:justify;} </style> <style id='colormag_style-inline-css' type='text/css'>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</style> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/add-to-any/addtoany.min.js' id='addtoany-js'></script> <script type='text/javascript' id='advanced-ads-advanced-js-js-extra'> /* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js' id='advanced-ads-advanced-js-js'></script> <script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'> /* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js' id='advanced_ads_pro/visitor_conditions-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/advanced-ds-pro/front.min.js' id='advanced-ds-pro/front-js'></script> <!--[if lte IE 8]> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/html5shiv.min.js' id='html5-js'></script> <![endif]--> <script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'> /* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"1","lazy_load":{"default_offset":200,"offsets":[]},"moveintohidden":""};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js' id='advanced-ads-pro/cache_busting-js'></script><link rel="https://api.w.org/" href="https://www.plumasnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.plumasnews.com/wp-json/wp/v2/posts/36548" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.plumasnews.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.plumasnews.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.6" /><link rel='shortlink' href='https://www.plumasnews.com/?p=36548' /><link rel="alternate" type="application/json+oembed" href="https://www.plumasnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.plumasnews.com%2Fseneca-collecting-valentines-for-its-senior-nursing-residents%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.plumasnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.plumasnews.com%2Fseneca-collecting-valentines-for-its-senior-nursing-residents%2F&#038;format=xml" /> <script data-cfasync="false"> window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script"); </script> <!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-11530911-1"></script> <script> window.dataLayer = window.dataLayer || [];
 function gtag(){dataLayer.push(arguments);}
 gtag('js', new Date());  gtag('config', 'UA-11530911-1'); </script><script type="text/javascript"> var advadsCfpQueue = [];
 var advadsCfpAd = function( adID ){
 if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
 }; </script> <style type="text/css" id="custom-background-css"> body.custom-background { background-color: #828282; } </style> <script type="text/javascript"> if ( 'undefined' == typeof advadsGATracking ) window.advadsGATracking = {}; </script><link rel="icon" href="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-32x32.jpg" sizes="32x32" /><link rel="icon" href="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-192x192.jpg" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-180x180.jpg" /><meta name="msapplication-TileImage" content="https://www.plumasnews.com/wp-content/uploads/2020/03/cropped-favicon_plumasnews-1-270x270.jpg" /> <style type="text/css" id="wp-custom-css"> .has-vivid-cyan-blue-color:hover {
 background-color: #1e73be;
 color: white;
}  .tg-footer-main-widget {
 width: 29.473684%;
 float: left;
 margin-right: 2.631579%;
}  .tg-footer-other-widgets {
 float: right;
 width: 67.894737%;
}  .myButton {
 background:linear-gradient(to bottom, #ffcd05 5%, #ff9900 100%);
 background-color:#ffcd05;
 border-radius:5px;
 border:1px solid #ffee00;
 display:inline-block;
 cursor:pointer;
 color:#0f0f0f;
 font-family:Arial;
 font-size:17px;
 font-weight:bold;
 padding:10px 31px;
 text-decoration:none;
}
.myButton:hover {
 background:linear-gradient(to bottom, #ff9900 5%, #ffcd05 100%);
 background-color:#ff9900;
}
.myButton:active {
 position:relative;
 top:1px;
} </style></head><body class="post-template-default single single-post postid-36548 single-format-standard custom-background wp-embed-responsive right-sidebar box-layout better-responsive-menu aa-prefix-pluma-"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a><header id="masthead" class="site-header clearfix "><div id="header-text-nav-container" class="clearfix"><div class="news-bar"><div class="inner-wrap clearfix"><div class="date-in-header"> Friday, February 5, 2021</div><div class="breaking-news"> <strong class="breaking-news-latest">Latest:</strong><ul class="newsticker"><li> <a href="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/" title="Seneca collecting Valentines for its senior nursing residents"> Seneca collecting Valentines for its senior nursing residents </a></li><li> <a href="https://www.plumasnews.com/quincy-weather-summary-feb-1-5/" title="Quincy Weather Summary Feb. 1-5"> Quincy Weather Summary Feb. 1-5 </a></li><li> <a href="https://www.plumasnews.com/letter-to-the-editor-trumps-impeachment-is-not-unconstitutional/" title="Letter to the Editor: Trump&#8217;s impeachment is not unconstitutional"> Letter to the Editor: Trump&#8217;s impeachment is not unconstitutional </a></li><li> <a href="https://www.plumasnews.com/groundhog-fever-festival-checkout-the-video-and-the-chili/" title="Groundhog Fever Festival: Checkout the video and the chili"> Groundhog Fever Festival: Checkout the video and the chili </a></li><li> <a href="https://www.plumasnews.com/unsafe-passing-maneuver-results-in-fatality/" title="Unsafe passing maneuver results in fatality"> Unsafe passing maneuver results in fatality </a></li></ul></div><div class="social-links clearfix"><ul><li><a href="https://www.facebook.com/plumasnews" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://www.twitter.com/plumasnews" target="_blank"><i class="fa fa-twitter"></i></a></li></ul></div><!-- .social-links --></div></div><div id="wp-custom-header" class="wp-custom-header"><div class="header-image-wrap"><img src="https://www.plumasnews.com/wp-content/uploads/2019/04/plumasnews-flag-chopped-1.jpg" class="header-image" width="1200" height="237" alt="Plumas News"></div></div><div class="inner-wrap"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class="screen-reader-text"><h3 id="site-title"> <a href="https://www.plumasnews.com/" title="Plumas News" rel="home">Plumas News</a></h3><p id="site-description"> Plumas County News</p><!-- #site-description --></div><!-- #header-text --></div><!-- #header-left-section --><div id="header-right-section"></div><!-- #header-right-section --></div><!-- #header-text-nav-wrap --></div><!-- .inner-wrap --><nav id="site-navigation" class="main-navigation clearfix" role="navigation"><div class="inner-wrap clearfix"><div class="home-icon"> <a href="https://www.plumasnews.com/"
 title="Plumas News"
 > <i class="fa fa-home"></i> </a></div><div class="search-random-icons-container"><div class="top-search-wrap"> <i class="fa fa-search search-top"></i><div class="search-form-top"><form action="https://www.plumasnews.com/" class="search-form searchform clearfix" method="get" role="search"><div class="search-wrap"> <input type="search"
 class="s field"
 name="s"
 value=""
 placeholder="Search"
 /> <button class="search-icon" type="submit"></button></div></form><!-- .searchform --></div></div></div><p class="menu-toggle"></p><div class="menu-primary-container"><ul id="menu-menu-1" class="menu"><li id="menu-item-381" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-381"><a href="https://www.plumasnews.com/category/news/">News</a></li><li id="menu-item-19111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19111"><a href="https://www.plumasnews.com/category/vitals/">Vitals</a><ul class="sub-menu"><li id="menu-item-19112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19112"><a href="https://www.plumasnews.com/category/vitals/births/">Births</a></li><li id="menu-item-19114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19114"><a href="https://www.plumasnews.com/category/vitals/life-tributes/">Life Tributes</a></li><li id="menu-item-19113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19113"><a href="https://www.plumasnews.com/category/vitals/death-notices/">Death Notices</a></li><li id="menu-item-19115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19115"><a href="https://www.plumasnews.com/category/vitals/marriage-licenses/">Marriage Licenses</a></li></ul></li><li id="menu-item-19091" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19091"><a href="https://www.plumasnews.com/category/law-order/">Law &amp; Order</a><ul class="sub-menu"><li id="menu-item-19092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19092"><a href="https://www.plumasnews.com/category/law-order/chp-report/">CHP Report</a></li><li id="menu-item-19093" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19093"><a href="https://www.plumasnews.com/category/law-order/criminal-case-update/">Criminal Case Update</a></li><li id="menu-item-34887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34887"><a href="https://www.plumasnews.com/category/law-order/sheriff-blotter/">Sheriff Blotter</a></li></ul></li><li id="menu-item-19095" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19095"><a href="https://www.plumasnews.com/category/opinion/">Opinion</a><ul class="sub-menu"><li id="menu-item-19096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19096"><a href="https://www.plumasnews.com/category/opinion/animal-tales/">Animal Tales</a></li><li id="menu-item-19098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19098"><a href="https://www.plumasnews.com/category/opinion/card-of-thanks/">Card of Thanks</a></li><li id="menu-item-19100" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19100"><a href="https://www.plumasnews.com/category/opinion/community-green/">Community Green</a></li><li id="menu-item-19101" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19101"><a href="https://www.plumasnews.com/category/opinion/editorial/">Editorial</a></li><li id="menu-item-19102" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19102"><a href="https://www.plumasnews.com/category/opinion/letters-to-the-editor/">Letter to the Editor</a></li><li id="menu-item-19105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19105"><a href="https://www.plumasnews.com/category/opinion/where-i-stand/">Where I Stand</a></li></ul></li><li id="menu-item-19106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-19106"><a href="https://www.plumasnews.com/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-19107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19107"><a href="https://www.plumasnews.com/category/sports/fish-bits/">Fish Bits</a></li><li id="menu-item-19108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19108"><a href="https://www.plumasnews.com/category/sports/golf-results/">Golf Results</a></li></ul></li><li id="menu-item-4253" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4253"><a>Publications</a><ul class="sub-menu"><li id="menu-item-35096" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35096"><a href="https://www.plumasnews.com/wp-content/uploads/2021/01/HCLFeb21.pdf">High Country Life</a></li><li id="menu-item-4252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4252"><a href="https://www.plumasnews.com/plumas-county-visitors-guide/">Plumas County Visitors Guide</a></li><li id="menu-item-4251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4251"><a href="https://www.plumasnews.com/plumas-county-dining-guide/">Plumas County Dining Guide</a></li><li id="menu-item-16212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16212"><a href="https://www.plumasnews.com/plumas-lassen-connection/">Plumas Lassen Connection</a></li><li id="menu-item-4250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4250"><a href="https://www.plumasnews.com/plumas-county-book-maps/">Plumas County Book of Maps</a></li><li id="menu-item-4248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4248"><a href="https://www.plumasnews.com/paying-tribute-150th-anniversary/">Paying Tribute to our 150th Anniversary</a></li><li id="menu-item-10461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10461"><a href="http://www.lassennews.com/lassen-county-visitors-guide/">Lassen County Visitors Guide</a></li><li id="menu-item-16213" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16213"><a href="https://www.lassennews.com/wp-content/uploads/2021/01/LMB20x.pdf">Lassen County Book of Maps</a></li><li id="menu-item-4744" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4744"><a href="http://www.lassennews.com">Lassen News</a></li></ul></li><li id="menu-item-29097" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29097"><a href="https://www.plumasnews.com/category/public-notices/">Public Notices</a><ul class="sub-menu"><li id="menu-item-34783" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34783"><a href="https://www.plumasnews.com/category/public-notices/">Plumas County Public Notices</a></li><li id="menu-item-33677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33677"><a href="https://www.lassennews.com/category/public-notices/lassen-county-public-notices/">Lassen County Public Notices</a></li><li id="menu-item-29099" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-29099"><a href="http://www.capublicnotice.com/">Statewide Public Notices</a></li></ul></li><li id="menu-item-36547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-36547"><a href="#">Weather</a><ul class="sub-menu"><li id="menu-item-36545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36545"><a href="https://www.plumasnews.com/weather-road-conditions/">Weather &#038; Road Conditions</a></li><li id="menu-item-36546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36546"><a href="https://www.plumasnews.com/category/weekly-temperatures/">Weekly Temperatures</a></li></ul></li><li id="menu-item-19151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-19151"><a href="https://www.plumasnews.com/contact-2/">Contact</a><ul class="sub-menu"><li id="menu-item-30459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30459"><a href="https://www.plumasnews.com/submit-to-plumas-news/">Submit to Plumas News</a></li></ul></li><li id="menu-item-32791" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32791"><a href="https://www.plumasnews.com/subscribe/">Subscribe</a></li><li id="menu-item-34004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34004"><a href="https://www.plumasnews.com/donate/">Donate</a></li></ul></div></div></nav></div><!-- #header-text-nav-container --></header><div id="main" class="clearfix"><div class="inner-wrap clearfix"><div class="front-page-top-section clearfix"><div class="widget_slider_area"><section id="advads_ad_widget-8" class="widget pluma-widget clearfix"><div class="pluma-fc14e83df1ba799d86d41d08d52c42fd" id="pluma-fc14e83df1ba799d86d41d08d52c42fd"></div></section></div><div class="widget_beside_slider"><section id="advads_ad_widget-9" class="widget pluma-widget clearfix"><div class="pluma-d8e38787346bc750b6179b70ebb42488" id="pluma-d8e38787346bc750b6179b70ebb42488"></div></section></div></div><div id="primary"><div id="content" class="clearfix"><article id="post-36548" class="post-36548 post type-post status-publish format-standard hentry category-news"><div class="caption-content"></div><div class="article-content clearfix"><div class="above-entry-meta"><span class="cat-links"><a href="https://www.plumasnews.com/category/news/" style="background:#848484" rel="category tag">News</a>&nbsp;</span></div><header class="entry-header"><h1 class="entry-title"> Seneca collecting Valentines for its senior nursing residents</h1></header><div class="below-entry-meta"> <span class="posted-on"><a href="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/" title="2:21 pm" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published updated" datetime="2021-02-05T14:21:43-08:00">February 5, 2021</time></a></span> <span class="byline"> <span class="author vcard"> <i class="fa fa-user"></i> <a class="url fn n"
 href="https://www.plumasnews.com/author/dmoore/"
 title="Editor"
 > Editor </a> </span> </span></div><div class="entry-content clearfix"><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_26 addtoany_list" data-a2a-url="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/" data-a2a-title="Seneca collecting Valentines for its senior nursing residents"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.plumasnews.com%2Fseneca-collecting-valentines-for-its-senior-nursing-residents%2F&amp;linkname=Seneca%20collecting%20Valentines%20for%20its%20senior%20nursing%20residents" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.plumasnews.com%2Fseneca-collecting-valentines-for-its-senior-nursing-residents%2F&amp;linkname=Seneca%20collecting%20Valentines%20for%20its%20senior%20nursing%20residents" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fwww.plumasnews.com%2Fseneca-collecting-valentines-for-its-senior-nursing-residents%2F&amp;linkname=Seneca%20collecting%20Valentines%20for%20its%20senior%20nursing%20residents" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><p>The Seneca Healthcare District is collecting Valentine&#8217;s Day cards for its senior nursing residents. &#8220;It has been a challenging year for all of our Senior Nursing Residents at Seneca Healthcare District,&#8221; said spokeswoman Chelssa Outland. &#8220;Help the senior nursing residents of Seneca experience the joy and love of the season with Valentine’s Day cards!&#8221;</p><p>There are 11 residents who would enjoy the cards.</p><div class="pluma-ba418d1f7358fa89897d9721e5d93406 pluma-pcph-mobile-box" id="pluma-ba418d1f7358fa89897d9721e5d93406"></div><p>The process is easy. Just follow these steps:<br /> Grab some Valentine’s Day Cards next time you’re at the store.<br /> Write a note or just sign your name.<br /> Send the cards to Seneca Healthcare District and staff will take care of the rest.</p><p>Cards can be dropped off at SHD Administration office or mailed to:<br /> Seneca Healthcare District<br /> Attn: Long-term Care<br /> PO Box 737, Chester Ca 96020</p><p><img loading="lazy" class="alignright wp-image-36549 size-full" src="https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-scaled.jpg" alt="" width="1810" height="2560" srcset="https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-scaled.jpg 1810w, https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-283x400.jpg 283w, https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-724x1024.jpg 724w, https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-150x212.jpg 150w, https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-768x1086.jpg 768w, https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-1086x1536.jpg 1086w, https://www.plumasnews.com/wp-content/uploads/2021/02/Pink-Valentines-Day-Sale-Poster-1-1448x2048.jpg 1448w" sizes="(max-width: 1810px) 100vw, 1810px" /></p></div></div></article></div><!-- #content --><ul class="default-wp-page clearfix"><li class="previous"><a href="https://www.plumasnews.com/quincy-weather-summary-feb-1-5/" rel="prev"><span class="meta-nav">&larr;</span> Quincy Weather Summary Feb. 1-5</a></li><li class="next"></li></ul> <!--BEGIN More News Section--><h3 id="more-news-h3">More News</h3><hr id="more-news-hr"> <style>.wp-show-posts-columns#wpsp-28237 {margin-left: -2em; }.wp-show-posts-columns#wpsp-28237 .wp-show-posts-inner {margin: 0 0 2em 2em; }</style><section id="wpsp-28237" class=" wp-show-posts-columns wp-show-posts" style=""><article class=" wp-show-posts-single post-36534 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/groundhog-fever-festival-checkout-the-video-and-the-chili/" rel="bookmark">Groundhog Fever Festival: Checkout the video and the chili</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/groundhog-fever-festival-checkout-the-video-and-the-chili/" title="12:52 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-05T12:52:49-08:00" itemprop="datePublished">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>It’s wild. It’s wacky. It’s weird. And, according to the Quincy Chamber of Commerce, it&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Groundhog Fever Festival: Checkout the video and the chili" class="more-link" href="https://www.plumasnews.com/groundhog-fever-festival-checkout-the-video-and-the-chili/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36524 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/testing-and-vaccinations-dominate-pdh-tests-120-frc-students/" rel="bookmark">Testing and vaccinations dominate; PDH tests 120 FRC students</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/testing-and-vaccinations-dominate-pdh-tests-120-frc-students/" title="9:50 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-05T09:50:06-08:00" itemprop="datePublished">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Testing and vaccinations continue to be the dual priorities of the Plumas County Public Health&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Testing and vaccinations dominate; PDH tests 120 FRC students" class="more-link" href="https://www.plumasnews.com/testing-and-vaccinations-dominate-pdh-tests-120-frc-students/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36526 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/lassen-high-school-grad-has-quadruplets/" rel="bookmark">Lassen High School grad has quadruplets</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/lassen-high-school-grad-has-quadruplets/" title="9:49 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-05T09:49:27-08:00" itemprop="datePublished">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Autumn Hedrick, a 2012 graduate of Lassen High School (now married and known as Autumn&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Lassen High School grad has quadruplets" class="more-link" href="https://www.plumasnews.com/lassen-high-school-grad-has-quadruplets/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36517 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/second-issue-of-high-country-life-magazine-is-now-on-the-newsstands/" rel="bookmark">Second issue of High Country Life magazine is now on the newsstands</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/second-issue-of-high-country-life-magazine-is-now-on-the-newsstands/" title="9:09 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-05T09:09:43-08:00" itemprop="datePublished">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Residents in Plumas, Lassen and Sierra counties will find the second monthly issue of “High&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Second issue of High Country Life magazine is now on the newsstands" class="more-link" href="https://www.plumasnews.com/second-issue-of-high-country-life-magazine-is-now-on-the-newsstands/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36505 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/feb-4-plumas-announces-just-1-new-case/" rel="bookmark">Feb. 4: Plumas announces just 1 new case</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/feb-4-plumas-announces-just-1-new-case/" title="5:16 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-04T17:16:15-08:00" itemprop="datePublished">February 4, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Plumas County Public Health Agency announced this afternoon, Feb.4, that there is just one&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Feb. 4: Plumas announces just 1 new case" class="more-link" href="https://www.plumasnews.com/feb-4-plumas-announces-just-1-new-case/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36507 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/plumas-arts-announces-its-lineup/" rel="bookmark">Plumas Arts shares its lineup of exhibits</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/plumas-arts-announces-its-lineup/" title="4:39 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-04T16:39:37-08:00" itemprop="datePublished">February 4, 2021</time><time class="wp-show-posts-updated" datetime="2021-02-05T09:15:13-08:00" itemprop="dateModified">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Plumas Arts Gallery is open again with its regular winter hours of Wednesday through&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Plumas Arts shares its lineup of exhibits" class="more-link" href="https://www.plumasnews.com/plumas-arts-announces-its-lineup/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36502 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/charting-precipitation-amounts-in-the-almanor-basin/" rel="bookmark">Charting precipitation amounts in the Almanor Basin</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/charting-precipitation-amounts-in-the-almanor-basin/" title="2:07 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-04T14:07:53-08:00" itemprop="datePublished">February 4, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>How does this year&#8217;s precipitation compare to years past? Lake Almanor resident Phil Datner investigated&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Charting precipitation amounts in the Almanor Basin" class="more-link" href="https://www.plumasnews.com/charting-precipitation-amounts-in-the-almanor-basin/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36499 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/fire-camp-brought-needed-funds-to-county-fairgrounds/" rel="bookmark">Fire camp brought needed funds to county fairgrounds</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/fire-camp-brought-needed-funds-to-county-fairgrounds/" title="11:32 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-04T11:32:06-08:00" itemprop="datePublished">February 4, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Debra Moore <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="a8ccc5c7c7dacde8d8c4ddc5c9dbc6cddfdb86cbc7c5">[email&#160;protected]</a> Despite all of the destruction and upheaval caused by last year’s&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Fire camp brought needed funds to county fairgrounds" class="more-link" href="https://www.plumasnews.com/fire-camp-brought-needed-funds-to-county-fairgrounds/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36491 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/spi-to-hold-virtual-career-fair-feb-18/" rel="bookmark">SPI to hold virtual career fair Feb. 18</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/spi-to-hold-virtual-career-fair-feb-18/" title="9:18 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-04T09:18:49-08:00" itemprop="datePublished">February 4, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Sierra Pacific Industries is hosting a Virtual Career Fair happening Thursday, Feb. 18,  with two&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="SPI to hold virtual career fair Feb. 18" class="more-link" href="https://www.plumasnews.com/spi-to-hold-virtual-career-fair-feb-18/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36485 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/plumas-bank-donates-25000-to-support-local-non-profits-addressing-food-insecurity/" rel="bookmark">Plumas Bank donates $25,000 to support local non-profits addressing food insecurity</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/plumas-bank-donates-25000-to-support-local-non-profits-addressing-food-insecurity/" title="8:56 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-04T08:56:24-08:00" itemprop="datePublished">February 4, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Plumas Bank, a wholly-owned subsidiary of Plumas Bancorp, recently announced that it donated $25,000 to&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Plumas Bank donates $25,000 to support local non-profits addressing food insecurity" class="more-link" href="https://www.plumasnews.com/plumas-bank-donates-25000-to-support-local-non-profits-addressing-food-insecurity/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36475 post type-post status-publish format-standard has-post-thumbnail hentry category-highlighted category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/audubon-hosts-owl-presentation-feb-11/" rel="bookmark">Audubon hosts owl presentation Feb. 11</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/audubon-hosts-owl-presentation-feb-11/" title="6:30 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-04T06:30:41-08:00" itemprop="datePublished">February 4, 2021</time><time class="wp-show-posts-updated" datetime="2021-02-05T13:25:12-08:00" itemprop="dateModified">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Plumas Audubon is hosting monthly speakers programs, which will continue Thursday, Feb. 11 at 7&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Audubon hosts owl presentation Feb. 11" class="more-link" href="https://www.plumasnews.com/audubon-hosts-owl-presentation-feb-11/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36461 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/feb-3-plumas-announces-3-new-cases/" rel="bookmark">Feb. 3: Plumas announces 3 new cases</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/feb-3-plumas-announces-3-new-cases/" title="4:58 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-03T16:58:49-08:00" itemprop="datePublished">February 3, 2021</time><time class="wp-show-posts-updated" datetime="2021-02-04T16:07:15-08:00" itemprop="dateModified">February 4, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Plumas County Public Health Agency announced this afternoon, Feb. 3, that there are three&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Feb. 3: Plumas announces 3 new cases" class="more-link" href="https://www.plumasnews.com/feb-3-plumas-announces-3-new-cases/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36468 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/public-hearings-on-portola-mine-likely-months-away/" rel="bookmark">Public hearings on Portola mine likely months away</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/public-hearings-on-portola-mine-likely-months-away/" title="1:55 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-03T13:55:22-08:00" itemprop="datePublished">February 3, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Plumas Country residents opposed to a proposed mine expansion near Portola have been voicing that&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Public hearings on Portola mine likely months away" class="more-link" href="https://www.plumasnews.com/public-hearings-on-portola-mine-likely-months-away/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36464 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/board-approves-filling-9-vacant-county-positions/" rel="bookmark">Board approves filling 9 vacant county positions</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/board-approves-filling-9-vacant-county-positions/" title="12:53 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-03T12:53:34-08:00" itemprop="datePublished">February 3, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Jobs and more jobs. The Plumas County Board of Supervisors approved filling nine positions during&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Board approves filling 9 vacant county positions" class="more-link" href="https://www.plumasnews.com/board-approves-filling-9-vacant-county-positions/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36455 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/caltrans-seeks-public-input-on-bike-pedestrian-improvements/" rel="bookmark">Caltrans seeks public input on bike/pedestrian improvements</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/caltrans-seeks-public-input-on-bike-pedestrian-improvements/" title="11:45 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-03T11:45:54-08:00" itemprop="datePublished">February 3, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The California Department of Transportation (Caltrans) needs public input on its active transportation planning process&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Caltrans seeks public input on bike/pedestrian improvements" class="more-link" href="https://www.plumasnews.com/caltrans-seeks-public-input-on-bike-pedestrian-improvements/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36451 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/community-pitching-in-to-build-downtown-bike-park/" rel="bookmark">Community pitching in to build downtown bike park</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/community-pitching-in-to-build-downtown-bike-park/" title="10:20 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-03T10:20:52-08:00" itemprop="datePublished">February 3, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Fundraising efforts are underway to build a bike park in downtown Quincy. Organizers of the&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Community pitching in to build downtown bike park" class="more-link" href="https://www.plumasnews.com/community-pitching-in-to-build-downtown-bike-park/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36447 post type-post status-publish format-standard hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/feather-river-college-recognizes-employees-with-longevity-service-awards/" rel="bookmark">Feather River College recognizes employees with longevity service awards</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/feather-river-college-recognizes-employees-with-longevity-service-awards/" title="9:07 am" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-03T09:07:06-08:00" itemprop="datePublished">February 3, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Feather River College recently honored several individuals for their longevity and exemplary service to students&#8230;.</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Feather River College recognizes employees with longevity service awards" class="more-link" href="https://www.plumasnews.com/feather-river-college-recognizes-employees-with-longevity-service-awards/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36439 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/feb-2-plumas-announces-just-one-new-case/" rel="bookmark">Feb. 2: Plumas announces just one new case</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/feb-2-plumas-announces-just-one-new-case/" title="5:01 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-02T17:01:44-08:00" itemprop="datePublished">February 2, 2021</time><time class="wp-show-posts-updated" datetime="2021-02-03T16:48:17-08:00" itemprop="dateModified">February 3, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>The Plumas County Public Health Agency announced this afternoon, Feb. 2, that there is just&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Feb. 2: Plumas announces just one new case" class="more-link" href="https://www.plumasnews.com/feb-2-plumas-announces-just-one-new-case/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36436 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/public-health-director-provides-vaccine-update/" rel="bookmark">Public Health Director provides vaccine update</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/public-health-director-provides-vaccine-update/" title="4:13 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-02T16:13:04-08:00" itemprop="datePublished">February 2, 2021</time><time class="wp-show-posts-updated" datetime="2021-02-05T13:14:23-08:00" itemprop="dateModified">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Debra Moore <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b1d5dcdedec3d4f1c1ddc4dcd0c2dfd4c6c29fd2dedc">[email&#160;protected]</a> Vaccine. Vaccine. Vaccine. “There continues to be not enough vaccine –&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Public Health Director provides vaccine update" class="more-link" href="https://www.plumasnews.com/public-health-director-provides-vaccine-update/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36426 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/area-high-schools-receive-ap-computer-science-female-diversity-award/" rel="bookmark">Area high schools receive AP Computer Science Female Diversity Award</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/area-high-schools-receive-ap-computer-science-female-diversity-award/" title="3:22 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-02T15:22:41-08:00" itemprop="datePublished">February 2, 2021</time><time class="wp-show-posts-updated" datetime="2021-02-05T09:13:41-08:00" itemprop="dateModified">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>Two Plumas Unified School District high schools are recipients of The College Board AP® Computer&#8230;</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="Area high schools receive AP Computer Science Female Diversity Award" class="more-link" href="https://www.plumasnews.com/area-high-schools-receive-ap-computer-science-female-diversity-award/">Read More</a></div></div><!-- wp-show-posts-inner --></article><article class=" wp-show-posts-single post-36430 post type-post status-publish format-standard has-post-thumbnail hentry category-news wpsp-col-4" itemtype="http://schema.org/CreativeWork" itemscope><div class="wp-show-posts-inner" style=""><header class="wp-show-posts-entry-header"> <span class="wp-show-posts-entry-title" itemprop="headline"><a href="https://www.plumasnews.com/the-plumas-board-of-supervisors-is-going-to-zoom/" rel="bookmark">The Plumas Board of Supervisors is going to Zoom</a></span><div class="wp-show-posts-entry-meta wp-show-posts-entry-meta-below-title post-meta-inline"><span class="wp-show-posts-posted-on wp-show-posts-meta"> <a href="https://www.plumasnews.com/the-plumas-board-of-supervisors-is-going-to-zoom/" title="3:19 pm" rel="bookmark"><time class="wp-show-posts-entry-date published" datetime="2021-02-02T15:19:58-08:00" itemprop="datePublished">February 2, 2021</time><time class="wp-show-posts-updated" datetime="2021-02-05T09:14:09-08:00" itemprop="dateModified">February 5, 2021</time></a> </span></div></header><!-- .entry-header --><div class="wp-show-posts-entry-summary" itemprop="text"><p>By Debra Moore <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e480898b8b9681a49488918985978a819397ca878b89">[email&#160;protected]</a> Welcome to Zoom. Beginning with its next meeting on Tuesday, Feb&#8230;.</p></div><!-- .entry-summary --><div class="wpsp-read-more"><a title="The Plumas Board of Supervisors is going to Zoom" class="more-link" href="https://www.plumasnews.com/the-plumas-board-of-supervisors-is-going-to-zoom/">Read More</a></div></div><!-- wp-show-posts-inner --></article><div class="wpsp-clear"></div></section><!-- .wp-show-posts --> <!--END More News Section--></div><!-- #primary --><div id="secondary"><aside id="custom_html-2" class="widget_text extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_custom_html clearfix"><h3 class="widget-title"><span>I want to support plumasnews.com</span></h3><div class="textwidget custom-html-widget"><a href="/donate" class="myButton">Click Here</a></div></aside><aside id="blog_subscription-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_blog_subscription jetpack_subscription_widget clearfix"><h3 class="widget-title"><span>Subscribe via Email</span></h3><form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2"><div id="subscribe-text"><p>Enter your email address to subscribe to Plumas News and receive notifications of new posts by email.</p></div><p id="subscribe-email"> <label id="jetpack-subscribe-label"
 class="screen-reader-text"
 for="subscribe-field-blog_subscription-2"> Email Address </label> <input type="email" name="email" required="required"
 value=""
 id="subscribe-field-blog_subscription-2"
 placeholder="Email Address"
 /></p><p id="subscribe-submit"> <input type="hidden" name="action" value="subscribe"/> <input type="hidden" name="source" value="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/"/> <input type="hidden" name="sub-type" value="widget"/> <input type="hidden" name="redirect_fragment" value="blog_subscription-2"/> <button type="submit"
 name="jetpack_subscriptions_widget"
 > Subscribe </button></p></form></aside><aside class="extendedwopts-show extendedwopts-desktop widget pluma-widget clearfix"><div class="pluma-28116ac2be691eaec94ed19519c9875c" id="pluma-28116ac2be691eaec94ed19519c9875c"></div></aside><aside id="text-5" class="widget widget_text clearfix"><div class="textwidget"><div class="pluma-78722c4629aa2cf2fb5831b8c8657563 pluma-sidebar-desktop-placement" id="pluma-78722c4629aa2cf2fb5831b8c8657563"></div></div></aside></div></div><!-- .inner-wrap --><div class="front-page-top-section clearfix"><div class="widget_slider_area"><section id="advads_ad_widget-8" class="widget pluma-widget clearfix"><div class="pluma-9461363583a16e8c173c650021cb918a" id="pluma-9461363583a16e8c173c650021cb918a"></div></section></div><div class="widget_beside_slider"><section id="advads_ad_widget-9" class="widget pluma-widget clearfix"><div class="pluma-df7700d671ceaf9a2248df88da34b4e8" id="pluma-df7700d671ceaf9a2248df88da34b4e8"></div></section></div></div></div><!-- #main --><div class="advertisement_above_footer"><div class="inner-wrap"><aside id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget clearfix"><div
 class="hide-on-button negative"
 data-hide-timeout="30"
 data-consent-expiration="180"
 id="eu-cookie-law"
><form method="post"> <input type="submit" value="Close and accept" class="accept" /></form> Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br /> To find out more, including how to control cookies, see here: <a href="https://www.plumasnews.com/privacy-policy-2/" rel=""> Cookie Policy </a></div></aside></div></div><footer id="colophon" class="clearfix "><div class="footer-widgets-wrapper"><div class="inner-wrap"><div class="footer-widgets-area clearfix"><div class="tg-footer-main-widget"><div class="tg-first-footer-widget"><aside id="blog_subscription-3" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_blog_subscription jetpack_subscription_widget clearfix"><h3 class="widget-title"><span>Subscribe via Email</span></h3><form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-3"><div id="subscribe-text"><p>Enter your email address to subscribe to Plumas News and receive notifications of new posts by email.</p></div><p id="subscribe-email"> <label id="jetpack-subscribe-label"
 class="screen-reader-text"
 for="subscribe-field-blog_subscription-3"> Email Address </label> <input type="email" name="email" required="required"
 value=""
 id="subscribe-field-blog_subscription-3"
 placeholder="Email Address"
 /></p><p id="subscribe-submit"> <input type="hidden" name="action" value="subscribe"/> <input type="hidden" name="source" value="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/"/> <input type="hidden" name="sub-type" value="widget"/> <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/> <button type="submit"
 name="jetpack_subscriptions_widget"
 > Subscribe </button></p></form></aside></div></div><div class="tg-footer-other-widgets"><div class="tg-second-footer-widget"><aside id="pages-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_pages clearfix"><h3 class="widget-title"><span>Pages</span></h3><ul><li class="page_item page-item-12086"><a href="https://www.plumasnews.com/contact-2/">Contact</a></li><li class="page_item page-item-33992"><a href="https://www.plumasnews.com/donate/">Donate</a></li><li class="page_item page-item-4246"><a href="https://www.plumasnews.com/paying-tribute-150th-anniversary/">Paying Tribute to our 150th Anniversary</a></li><li class="page_item page-item-4241"><a href="https://www.plumasnews.com/plumas-county-book-maps/">Plumas County Book of Maps</a></li><li class="page_item page-item-4239"><a href="https://www.plumasnews.com/plumas-county-dining-guide/">Plumas County Dining Guide</a></li><li class="page_item page-item-4237"><a href="https://www.plumasnews.com/plumas-county-visitors-guide/">Plumas County Visitors Guide</a></li><li class="page_item page-item-4244"><a href="https://www.plumasnews.com/plumas-lassen-connection/">Plumas-Lassen Connection</a></li><li class="page_item page-item-10888"><a href="https://www.plumasnews.com/privacy-policy-2/">Privacy Policy</a></li><li class="page_item page-item-30457"><a href="https://www.plumasnews.com/submit-to-plumas-news/">Submit to Plumas News</a></li><li class="page_item page-item-266"><a href="https://www.plumasnews.com/weather-road-conditions/">Weather &#038; Road Conditions</a></li></ul></aside></div><div class="tg-third-footer-widget"><aside id="categories-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_categories clearfix"><h3 class="widget-title"><span>Categories</span></h3><form action="https://www.plumasnews.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' ><option value='-1'>Select Category</option><option class="level-0" value="60">Business</option><option class="level-1" value="3">&nbsp;&nbsp;&nbsp;Business Scene</option><option class="level-1" value="61">&nbsp;&nbsp;&nbsp;Chamber Update</option><option class="level-0" value="70">Highlighted</option><option class="level-0" value="52">Law &amp; Order</option><option class="level-1" value="53">&nbsp;&nbsp;&nbsp;CHP Report</option><option class="level-1" value="55">&nbsp;&nbsp;&nbsp;Criminal Case Update</option><option class="level-1" value="54">&nbsp;&nbsp;&nbsp;Sheriff Blotter</option><option class="level-0" value="5">News</option><option class="level-0" value="7">Opinion</option><option class="level-1" value="49">&nbsp;&nbsp;&nbsp;Animal Tales</option><option class="level-1" value="51">&nbsp;&nbsp;&nbsp;C-Force</option><option class="level-1" value="50">&nbsp;&nbsp;&nbsp;Card of Thanks</option><option class="level-1" value="44">&nbsp;&nbsp;&nbsp;Commander&#8217;s Corner</option><option class="level-1" value="47">&nbsp;&nbsp;&nbsp;Community Green</option><option class="level-1" value="14">&nbsp;&nbsp;&nbsp;Editorial</option><option class="level-1" value="48">&nbsp;&nbsp;&nbsp;Letter to the Editor</option><option class="level-1" value="17">&nbsp;&nbsp;&nbsp;My Turn</option><option class="level-1" value="67">&nbsp;&nbsp;&nbsp;Plumas County Volunteers</option><option class="level-1" value="9">&nbsp;&nbsp;&nbsp;Remember When</option><option class="level-1" value="39">&nbsp;&nbsp;&nbsp;Where I Stand</option><option class="level-0" value="8">Public Notices</option><option class="level-0" value="10">Sports</option><option class="level-1" value="57">&nbsp;&nbsp;&nbsp;Fish Bits</option><option class="level-1" value="56">&nbsp;&nbsp;&nbsp;Golf Results</option><option class="level-1" value="58">&nbsp;&nbsp;&nbsp;Graeagle Peggers</option><option class="level-0" value="2">Vitals</option><option class="level-1" value="11">&nbsp;&nbsp;&nbsp;Births</option><option class="level-1" value="62">&nbsp;&nbsp;&nbsp;Death Notices</option><option class="level-1" value="6">&nbsp;&nbsp;&nbsp;Life Tributes</option><option class="level-1" value="46">&nbsp;&nbsp;&nbsp;Marriage Licenses</option><option class="level-0" value="80">Weekly Temperatures</option> </select></form> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript"> /* <![CDATA[ */
(function() {
 var dropdown = document.getElementById( "cat" );
 function onCatChange() {
 if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
 dropdown.parentNode.submit();
 }
 }
 dropdown.onchange = onCatChange;
})();
/* ]]> */ </script></aside></div><div class="tg-fourth-footer-widget"><aside id="recent-posts-2" class="extendedwopts-hide extendedwopts-tablet extendedwopts-mobile widget widget_recent_entries clearfix"><h3 class="widget-title"><span>Recent Posts</span></h3><ul><li> <a href="https://www.plumasnews.com/seneca-collecting-valentines-for-its-senior-nursing-residents/" aria-current="page">Seneca collecting Valentines for its senior nursing residents</a></li><li> <a href="https://www.plumasnews.com/quincy-weather-summary-feb-1-5/">Quincy Weather Summary Feb. 1-5</a></li><li> <a href="https://www.plumasnews.com/letter-to-the-editor-trumps-impeachment-is-not-unconstitutional/">Letter to the Editor: Trump&#8217;s impeachment is not unconstitutional</a></li><li> <a href="https://www.plumasnews.com/groundhog-fever-festival-checkout-the-video-and-the-chili/">Groundhog Fever Festival: Checkout the video and the chili</a></li><li> <a href="https://www.plumasnews.com/unsafe-passing-maneuver-results-in-fatality/">Unsafe passing maneuver results in fatality</a></li></ul></aside></div></div></div></div></div><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"><div class="footer-socket-right-section"><div class="social-links clearfix"><ul><li><a href="https://www.facebook.com/plumasnews" target="_blank"><i class="fa fa-facebook"></i></a></li><li><a href="https://www.twitter.com/plumasnews" target="_blank"><i class="fa fa-twitter"></i></a></li></ul></div><!-- .social-links --></div><div class="footer-socket-left-section"><div class="copyright">Copyright &copy; 2021 <a href="https://www.plumasnews.com/" title="Plumas News" ><span>Plumas News</span></a>. All rights reserved.<br>Theme: <a href="https://themegrill.com/themes/colormag" target="_blank" title="ColorMag" rel="nofollow"><span>ColorMag</span></a> by ThemeGrill. Powered by <a href="https://wordpress.org" target="_blank" title="WordPress" rel="nofollow"><span>WordPress</span></a>.</div></div></div><!-- .footer-socket-area --></div><!-- .inner-wrap --></div><!-- .footer-socket-wrapper --></footer><!-- #colophon --> <a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a></div><!-- #page --> <script type='text/javascript' id='contact-form-7-js-extra'> /* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.plumasnews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/contact-form-7.min.js' id='contact-form-7-js'></script> <script defer type='text/javascript' id='google-invisible-recaptcha-js-before'> var renderInvisibleReCaptcha = function() {  for (var i = 0; i < document.forms.length; ++i) {
 var form = document.forms[i];
 var holder = form.querySelector('.inv-recaptcha-holder');  if (null === holder) continue;
 holder.innerHTML = '';  (function(frm){
 var cf7SubmitElm = frm.querySelector('.wpcf7-submit');
 var holderId = grecaptcha.render(holder,{
 'sitekey': '6LdbLyIUAAAAANyBnSa49kZ4yVSmvqwoCI2GAJPi', 'size': 'invisible', 'badge' : 'inline',
 'callback' : function (recaptchaToken) {
 if((null !== cf7SubmitElm) && (typeof jQuery != 'undefined')){jQuery(frm).submit();grecaptcha.reset(holderId);return;}
 HTMLFormElement.prototype.submit.call(frm);
 },
 'expired-callback' : function(){grecaptcha.reset(holderId);}
 });  if(null !== cf7SubmitElm && (typeof jQuery != 'undefined') ){
 jQuery(cf7SubmitElm).off('click').on('click', function(clickEvt){
 clickEvt.preventDefault();
 grecaptcha.execute(holderId);
 });
 }
 else
 {
 frm.onsubmit = function (evt){evt.preventDefault();grecaptcha.execute(holderId);};
 }  })(form);
 }
};
</script> <script defer type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?onload=renderInvisibleReCaptcha#038;render=explicit&#038;siteground-async=1' id='google-invisible-recaptcha-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/jquery.bxslider.min.js' id='colormag-bxslider-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/news-ticker/jquery.newsTicker.min.js' id='colormag-news-ticker-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/magnific-popup/jquery.magnific-popup.min.js' id='colormag-featured-image-popup-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/navigation.min.js' id='colormag-navigation-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/fitvids/jquery.fitvids.min.js' id='colormag-fitvids-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/skip-link-focus-fix.min.js' id='colormag-skip-link-focus-fix-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/themes/colormag/js/colormag-custom.min.js' id='colormag-custom-js'></script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/jetpack/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script> <script type='text/javascript' id='advadsTrackingHandle-js-extra'> /* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/www.plumasnews.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":"ga","blogId":"1"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/advadsTrackingHandle.min.js' id='advadsTrackingHandle-js'></script> <script type='text/javascript' id='advadsTrackingGAFront-js-extra'> /* <![CDATA[ */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://www.plumasnews.com/wp-content/uploads/siteground-optimizer-assets/advadsTrackingGAFront.min.js' id='advadsTrackingGAFront-js'></script> <script type='text/javascript' src='https://www.plumasnews.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script> <script type='text/javascript' src='https://www.plumasnews.com/wp-content/plugins/wp-show-posts/js/jquery.matchHeight.js' id='wpsp-matchHeight-js'></script><div class="pluma-1952d10b24ffc17b87cd7e687f13a5d9 pluma-custom-placement" id="pluma-1952d10b24ffc17b87cd7e687f13a5d9"></div><script>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</script><script type="text/javascript">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</script><script type="text/javascript"> if ( 'undefined' == typeof window.advadsGATracking ) window.advadsGATracking = {};
 advadsGATracking.postContext = {"postID":36548,"postSlug":"seneca-collecting-valentines-for-its-senior-nursing-residents","cats":"news"}; </script></body></html>